summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:02:34 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-24 00:02:34 -0600
commit142373a4df26667cc9357bf6aa7e2e825c188002 (patch)
treeada71a3e4bd10021cbf0c447a9bced583b834ae4 /dev-python/os-traits/os-traits-0.5.0.ebuild
parentdev-python/pypowervm: 1.1.10 bup (diff)
downloadgentoo-142373a4df26667cc9357bf6aa7e2e825c188002.tar.gz
gentoo-142373a4df26667cc9357bf6aa7e2e825c188002.tar.bz2
gentoo-142373a4df26667cc9357bf6aa7e2e825c188002.zip
dev-python/os-traits: 0.5.0 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/os-traits/os-traits-0.5.0.ebuild')
-rw-r--r--dev-python/os-traits/os-traits-0.5.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/os-traits/os-traits-0.5.0.ebuild b/dev-python/os-traits/os-traits-0.5.0.ebuild
new file mode 100644
index 000000000000..9d648359e829
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}