summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-29 13:31:26 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-29 13:31:26 -0500
commit5452225d89c384130d02908a9fe3f52638db4612 (patch)
tree1dd4b666722c66bded254bd26d9e97ae45299967 /dev-python/os-win/os-win-0.4.0.ebuild
parentdev-python/os-brick: bup (diff)
downloadgentoo-5452225d89c384130d02908a9fe3f52638db4612.tar.gz
gentoo-5452225d89c384130d02908a9fe3f52638db4612.tar.bz2
gentoo-5452225d89c384130d02908a9fe3f52638db4612.zip
dev-python/os-win: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/os-win/os-win-0.4.0.ebuild')
-rw-r--r--dev-python/os-win/os-win-0.4.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/os-win/os-win-0.4.0.ebuild b/dev-python/os-win/os-win-0.4.0.ebuild
new file mode 100644
index 000000000000..fe9a8e0b6aab
--- /dev/null
+++ b/dev-python/os-win/os-win-0.4.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Windows / Hyper-V library for OpenStack projects."
+HOMEPAGE="https://github.com/openstack/os-win"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-1.14.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-service-1.0.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}