summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-06-02 13:39:59 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-06-02 13:40:37 -0500
commita9b254fbb9df8b488c487df528c33f1c56c5194c (patch)
treec3ff4f876e47338192927335291f7e15c453af15 /dev-python/oslo-cache/oslo-cache-2.3.0.ebuild
parentdev-python/oslo-serialization: 3.1.1 bump (diff)
downloadgentoo-a9b254fbb9df8b488c487df528c33f1c56c5194c.tar.gz
gentoo-a9b254fbb9df8b488c487df528c33f1c56c5194c.tar.bz2
gentoo-a9b254fbb9df8b488c487df528c33f1c56c5194c.zip
dev-python/oslo-cache: 2.3.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-cache/oslo-cache-2.3.0.ebuild')
-rw-r--r--dev-python/oslo-cache/oslo-cache-2.3.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild b/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild
new file mode 100644
index 000000000000..617334205e5a
--- /dev/null
+++ b/dev-python/oslo-cache/oslo-cache-2.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Caching around dogpile.cache"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/dogpile-cache-0.6.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.30.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.31.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+)
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}