summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-24 22:28:50 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-24 22:32:16 -0500
commit2c1602a662900bfb6683ac6ef2ffc1c4ee8f794d (patch)
treedec2f2b2a75fe73d486ffe5a8d72a074cb99dbbf /dev-python/oslo-concurrency
parentdev-python/eventlet: readding arm64 support (diff)
downloadgentoo-2c1602a662900bfb6683ac6ef2ffc1c4ee8f794d.tar.gz
gentoo-2c1602a662900bfb6683ac6ef2ffc1c4ee8f794d.tar.bz2
gentoo-2c1602a662900bfb6683ac6ef2ffc1c4ee8f794d.zip
dev-python/oslo-concurrency: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.6.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index e7df940cdf2f..dc75d256d2ea 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -2,3 +2,4 @@ DIST oslo.concurrency-1.8.0.tar.gz 52531 SHA256 2070e04106d9d3bdffdd9729a1f0b62a
DIST oslo.concurrency-1.8.1.tar.gz 53044 SHA256 12c5339c9263c994feb5c59290f7fb0eab12d6b729284efd01dd324c95bdecbb SHA512 227c16dd6916bd48ec937520650196b80bbbdf3988e7d6095eecd1ded601e207f24f63598881276591403e3b7c6e85f9adcce5a8ca210f82cffc75eff2351422 WHIRLPOOL 48bf1ffd9b04d0c5f199a8a6ff2deec6e25557a5af680450d30441b715edf0fea986c6620fb9a0ab722b13ca5f4664d39450db5e23cc96a331ed65532abf7a5a
DIST oslo.concurrency-1.8.2.tar.gz 53278 SHA256 149f4c972916f14c14c97d7be7b92ba59497c1bbd09c114ee3681bef0773daca SHA512 b73b52cef9dca932b8d0b737bd544f0a6d138de701aa9d2309d6e7698af337e4aea5cbb47c78c2ebda14abc164b8cc2b40fee6c8e92a30ee674318f436cf3b94 WHIRLPOOL 1ad6cc6dc0d339b2bec4959539fdadfb0914b1677005e250b4e74da3be97310474d20514003b0c0f50a4c6dff021ac8efa25e1f9b4502f419ab9763117caa16e
DIST oslo.concurrency-2.5.0.tar.gz 35903 SHA256 279c7cca885f69cfb7b3b50d686cd3d7c8d50dfb8eb13aada01bf733ef5ccc45 SHA512 866c3b7ea938c2b1fed7a004a34398b99fd6b084ca3c709a8448464f4845445a16fc1a016ea30b391190625ac53bf6756509dfbee28c89000f689743622246e0 WHIRLPOOL 0067b6d3089d94c41491e5e208392bad7cd7eebb9d7ba9c5300b985cfbad924273c30ec575674ba2177fe4ba3b17fe2dcd709c778753b013989bfb285070aa2b
+DIST oslo.concurrency-3.6.0.tar.gz 39546 SHA256 21726ea22125ec3e6076cc13b64ef25b60b31b6eca646c57f0d152f295695353 SHA512 561f3e99f8e2a013b381b95f035a3bd7da5cc3989ba93019fd2abffcdec71cc4cef17b71c1eaf34922a90f0241d9551e5214f71f6fb1c17b83b3033d0e63dfe1 WHIRLPOOL 2cfc1adffb83e8fcd910bcab075a1c5c8a4f0ed4ecebb9cf74428b86ca688b031bac0cf3fabf2951deeda68228f4b4c46e6c9ff0a45cafa52669b5c98985b879
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.6.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.6.0.ebuild
new file mode 100644
index 000000000000..a9c8b22193e6
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-3.6.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.concurrency"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDPEND="
+ >=dev-python/pbr-1.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-2.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.5.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7[${PYTHON_USEDEP}]
+ >=dev-python/retrying-1.2.3[${PYTHON_USEDEP}]
+ !~dev-python/retrying-1.3.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^futures/d' test-requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}