summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-02-11 12:23:53 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2020-02-11 13:05:51 -0600
commitaa4c708c8774dc3a61667752ad275480afe93dbf (patch)
treecabfadbae2ecbc354580653ec5434ab2bdc2c4c9 /dev-python/oslo-concurrency
parentdev-python/oslo-context: cleanup (diff)
downloadgentoo-aa4c708c8774dc3a61667752ad275480afe93dbf.tar.gz
gentoo-aa4c708c8774dc3a61667752ad275480afe93dbf.tar.bz2
gentoo-aa4c708c8774dc3a61667752ad275480afe93dbf.zip
dev-python/oslo-concurrency: cleanup
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 0b5a0662031d..a6bb56ffd320 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,2 +1 @@
-DIST oslo.concurrency-3.27.0.tar.gz 49604 BLAKE2B 04a7ed66c6d7cf37014080113bd3782cf186f57f486d6834fd28f3d518141f8dcac6f5e67ffb5ef894bc6f5085a90aa41a041e35b72325c645f7567dd743a912 SHA512 fb2e1377a8bbad451ef0a2713dfbcd58ec06d455e97fc4d8acf8bfde8eb27d59826d68dd3411bd60b6d6b5e68ff629f0e6e4781b17dd4349bc5b87f17c8b9d52
DIST oslo.concurrency-3.29.1.tar.gz 51785 BLAKE2B 4035981fcff3cb4384209f3b640b928dfacd13e324c9df1dfebb0c5230727736ff803b478e506b08ac4bd7bd405763b93bdb951b01751a5e293daa33df860c8e SHA512 f820b07dbb26be9170c7ded08ce96bebc8c8cbfa72a3be56e0cb0fd7a025160fe630ad256c8c5b1adc9059cd1608c3625513b3da311e5a611866280d2b65424e
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild
deleted file mode 100644
index 77d41a1f4fd2..000000000000
--- a/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="library for running multi-thread, multi-process applications"
-HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
-S="${WORKDIR}/oslo.concurrency-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
- >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
- >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
- !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- virtual/python-enum34[${PYTHON_USEDEP}]
- >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^futures/d' test-requirements.txt || die
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
-}