summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-22 10:14:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-22 12:28:07 +0200
commitaf4247da784c4d2a16e2f731e0faf988bb01ed14 (patch)
tree514f61554ebddf3e281fc3799c3f5bd1af4ffb7e /dev-python/oslo-concurrency
parentapp-admin/awscli: Bump to 1.21.1 (diff)
downloadgentoo-af4247da784c4d2a16e2f731e0faf988bb01ed14.tar.gz
gentoo-af4247da784c4d2a16e2f731e0faf988bb01ed14.tar.bz2
gentoo-af4247da784c4d2a16e2f731e0faf988bb01ed14.zip
dev-python/oslo-concurrency: Bump to 4.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest1
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 6f2a74b2b861..9115442dd1d0 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1 +1,2 @@
DIST oslo.concurrency-4.4.1.tar.gz 58399 BLAKE2B ea28cdd53ae124fe458c0d901b305d99b7a5b5525835e6a04ca856177876fa6c6a1eff74842dcf260c78c205d95f353cd1b70f0cb6205e7bec841bae2d6ecd0d SHA512 1b7e6a2cb2e3ee0710f652489522c7a9e47a5292c46041f21a2ffe4c61a6bbae48b43e93507465013704b89778deec860da06fec32b4d3778e05cade9a6d39a1
+DIST oslo.concurrency-4.5.0.tar.gz 58979 BLAKE2B 9e2eb4a233985a33994aeaf335c195c980e1e9dd8b48a7c4e53ae502599f12c0dc65466ee45569a97b72f1face0e80ce166922ca3e42f6ad28fd5b27bdf884a3 SHA512 13a2f4d39d3241370374e6fe4ea6047dfc4d20da6116aaebd27f085fdbce089d58b0ebab4f1224234c88237cdefafc2f96229e6527bf5cda13ef1e471e25a50c
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild
new file mode 100644
index 000000000000..6ee2324081d6
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-4.5.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/ https://github.com/openstack/oslo.concurrency"
+SRC_URI="mirror://pypi/o/${PN/-/.}/${PN/-/.}-${PV}.tar.gz"
+S="${WORKDIR}/${PN/-/.}-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND=">dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.19.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests unittest