summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-07-06 11:40:10 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-07-06 11:57:58 -0500
commitef94747c7b56ada11db85aca365dd6bbc8e820bb (patch)
tree130a56fe1de2478f0beea9bee33b4e910bc33364 /dev-python/oslo-context/oslo-context-2.12.2.ebuild
parentdev-python/stevedore: 1.20.1 bup (diff)
downloadgentoo-ef94747c7b56ada11db85aca365dd6bbc8e820bb.tar.gz
gentoo-ef94747c7b56ada11db85aca365dd6bbc8e820bb.tar.bz2
gentoo-ef94747c7b56ada11db85aca365dd6bbc8e820bb.zip
dev-python/oslo-context: 2.12.2 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.12.2.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.12.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.12.2.ebuild b/dev-python/oslo-context/oslo-context-2.12.2.ebuild
new file mode 100644
index 000000000000..87096c97748d
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.12.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.1.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}