summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 20:32:07 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:24:23 -0500
commit902591cf8ec60c9912632100ddac83978d794560 (patch)
tree9a0ee32eaaa50121725b79a44175fb3c7122db7b /dev-python/oslo-context/oslo-context-2.17.0.ebuild
parentdev-python/oslo-config: 4.11.0 bup (diff)
downloadgentoo-902591cf8ec60c9912632100ddac83978d794560.tar.gz
gentoo-902591cf8ec60c9912632100ddac83978d794560.tar.bz2
gentoo-902591cf8ec60c9912632100ddac83978d794560.zip
dev-python/oslo-context: 2.17.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/oslo-context/oslo-context-2.17.0.ebuild')
-rw-r--r--dev-python/oslo-context/oslo-context-2.17.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/oslo-context/oslo-context-2.17.0.ebuild b/dev-python/oslo-context/oslo-context-2.17.0.ebuild
new file mode 100644
index 000000000000..14c2209fa7fe
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.17.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.11.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.1.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}