summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 09:48:39 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit071a93a761a670f3b3abfc787b7f5baa7215a4c9 (patch)
tree0ef01afdef6a48e7559679a79ca2ecd2b4939442 /dev-python/oslo-context
parentdev-python/oslo-config: Add python3.5 support (diff)
downloadgentoo-071a93a761a670f3b3abfc787b7f5baa7215a4c9.tar.gz
gentoo-071a93a761a670f3b3abfc787b7f5baa7215a4c9.tar.bz2
gentoo-071a93a761a670f3b3abfc787b7f5baa7215a4c9.zip
dev-python/oslo-context: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/oslo-context')
-rw-r--r--dev-python/oslo-context/oslo-context-0.6.0.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/dev-python/oslo-context/oslo-context-0.6.0.ebuild b/dev-python/oslo-context/oslo-context-0.6.0.ebuild
index f36fa33e654a..9d9fc4e39e66 100644
--- a/dev-python/oslo-context/oslo-context-0.6.0.ebuild
+++ b/dev-python/oslo-context/oslo-context-0.6.0.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
DESCRIPTION="Helpers to maintain useful information about a request context"
HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
-S="${WORKDIR}/oslo.context-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -34,6 +34,8 @@ RDEPEND="
>=dev-python/Babel-1.3[${PYTHON_USEDEP}]
"
+S="${WORKDIR}/oslo.context-${PV}"
+
python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all