summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/oslo-context
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/oslo-context')
-rw-r--r--dev-python/oslo-context/Manifest1
-rw-r--r--dev-python/oslo-context/oslo-context-2.9.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/oslo-context/Manifest b/dev-python/oslo-context/Manifest
index d27550463e0b..602d460dd815 100644
--- a/dev-python/oslo-context/Manifest
+++ b/dev-python/oslo-context/Manifest
@@ -1 +1,2 @@
DIST oslo.context-2.2.0.tar.gz 16981 SHA256 8c9fbbf56d3f37cf00a039cac3455cffeb6588f61537e36a36ce9447c4be72ec SHA512 f4ccb7a5e652a4820fb40e538a631c11be5f978de2219dc923e18559d30625a31e0ca031f095ce2e0545290cdfdeb714fcf086add6b5a7eb2413ebd1e7a25875 WHIRLPOOL a9a5685dd62105ddaee9c48fdc96231ea700ab8821e7e918920afc1bdf1f1a0e36aa1845c9665bf753fb56d95005f69d4927b12aac9712f41f43e2d89682beaf
+DIST oslo.context-2.9.0.tar.gz 23049 SHA256 2682d59ebea3c61421bba98cd3f36dcef5416ad771b220856f14fb528ef81b39 SHA512 6aa062542953007d8cfaf05e231105865c35370a80c9b32a4faae266d07981e83ebe34790b0217d818e2bb40d82d0a7ef3ebf77c7008ce358f7b4e61f6a38ff8 WHIRLPOOL 7ab7cca5c1d5e260e5e97df7cc1a3136e6f96f8237251c3bed46ebc565a9706fcabaa8b138d14e61024d34f34e7be83da313c02e8eba502d68d9b9a1342e1cde
diff --git a/dev-python/oslo-context/oslo-context-2.9.0.ebuild b/dev-python/oslo-context/oslo-context-2.9.0.ebuild
new file mode 100644
index 000000000000..d84ca16c6406
--- /dev/null
+++ b/dev-python/oslo-context/oslo-context-2.9.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Helpers to maintain useful information about a request context"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.context"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/positional-1.0.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.context-${PV}"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+# This time half the doc files are missing; Do you want them?
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}