summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-09 09:50:23 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-09 10:33:03 +0100
commit0636a46bb5831fb5d6fcfac2bedd3f5bdf893939 (patch)
tree5d67993de339aca2ffd30b402f42411af34054ab /dev-python/oslo-log/oslo-log-1.10.0.ebuild
parentdev-python/oslo-i18n: Add python3.5 support (diff)
downloadgentoo-0636a46bb5831fb5d6fcfac2bedd3f5bdf893939.tar.gz
gentoo-0636a46bb5831fb5d6fcfac2bedd3f5bdf893939.tar.bz2
gentoo-0636a46bb5831fb5d6fcfac2bedd3f5bdf893939.zip
dev-python/oslo-log: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/oslo-log/oslo-log-1.10.0.ebuild')
-rw-r--r--dev-python/oslo-log/oslo-log-1.10.0.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-python/oslo-log/oslo-log-1.10.0.ebuild b/dev-python/oslo-log/oslo-log-1.10.0.ebuild
index 4385c2abe541..8672bf191e5e 100644
--- a/dev-python/oslo-log/oslo-log-1.10.0.ebuild
+++ b/dev-python/oslo-log/oslo-log-1.10.0.ebuild
@@ -1,17 +1,16 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
inherit distutils-r1
-DESCRIPTION="OpenStack logging config library provides standardized configuration for all openstack projects."
+DESCRIPTION="OpenStack logging config library"
HOMEPAGE="https://pypi.python.org/pypi/oslo.log https://github.com/openstack/oslo.log"
SRC_URI="mirror://pypi/o/oslo.log/oslo.log-${PV}.tar.gz"
-S="${WORKDIR}/oslo.log-${PV}"
LICENSE="Apache-2.0"
SLOT="0"
@@ -50,6 +49,8 @@ DEPEND="
dev-python/nose[${PYTHON_USEDEP}]
)"
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
python_prepare_all() {
sed -i '/^hacking/d' test-requirements.txt || die
distutils-r1_python_prepare_all