summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:43:28 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-07-02 18:54:09 -0500
commit459cb3a7a1e7f236e36ada4821398e88edfb5208 (patch)
tree37bb14211b9facbcf56cb33dd255aa7a268817a7 /dev-python/oslo-policy/oslo-policy-3.1.1.ebuild
parentdev-python/oslo-cache: 2.3.0 stable amd64/x86 (diff)
downloadgentoo-459cb3a7a1e7f236e36ada4821398e88edfb5208.tar.gz
gentoo-459cb3a7a1e7f236e36ada4821398e88edfb5208.tar.bz2
gentoo-459cb3a7a1e7f236e36ada4821398e88edfb5208.zip
dev-python/oslo-policy: 3.1.1 stable amd64/x86 with cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.23 RepoMan-Options: --force Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-policy/oslo-policy-3.1.1.ebuild')
-rw-r--r--dev-python/oslo-policy/oslo-policy-3.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/oslo-policy-3.1.1.ebuild b/dev-python/oslo-policy/oslo-policy-3.1.1.ebuild
new file mode 100644
index 000000000000..6e917950a2e5
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-3.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Support for RBAC policy enforcement across all OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.policy/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.40.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.policy-${PV}"