summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2020-05-16 11:12:02 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2020-05-16 11:58:17 -0500
commit858e6960d29b410c1ceb6fae9e968e16f85e4569 (patch)
tree7a0f435c2471cdbb40e5e6b84a44971a40259973 /dev-python/oslo-policy
parentxfce-base/xfconf: Add an explicit dependency on dbus (diff)
downloadgentoo-858e6960d29b410c1ceb6fae9e968e16f85e4569.tar.gz
gentoo-858e6960d29b410c1ceb6fae9e968e16f85e4569.tar.bz2
gentoo-858e6960d29b410c1ceb6fae9e968e16f85e4569.zip
dev-python/oslo-policy: 3.1.0 bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/oslo-policy')
-rw-r--r--dev-python/oslo-policy/Manifest1
-rw-r--r--dev-python/oslo-policy/oslo-policy-3.1.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/oslo-policy/Manifest b/dev-python/oslo-policy/Manifest
index b405d591a8c9..01a3be7c7d2c 100644
--- a/dev-python/oslo-policy/Manifest
+++ b/dev-python/oslo-policy/Manifest
@@ -1 +1,2 @@
DIST oslo.policy-2.3.3.tar.gz 93581 BLAKE2B 50d1b45b596242b901a5b583b412c90d55b2ea9501dab29fa24be7b1c64eacf89f0f7df742f897503ab3c09399bfca25b93ed9cc3aa2377a72986f73bb96f1e4 SHA512 b4a2febe240582dbad8306e2208bfb7bd83c2783002544428b5888a8930d959919f10044eb2c30579e2fe61a6958ebefce4300f1778798b201714232a2edb88f
+DIST oslo.policy-3.1.0.tar.gz 94290 BLAKE2B 90257806c834317b509d7b7e72ed00166b71fb692c68d86ce9ef3a4fe2fa671625ba677a4b86fd2ab43f4cc04d1b7f54314c80c1baea8baf0d116689cd178618 SHA512 61f7267abb1268627ba50f2a7d4196c6a6805aa3bbb5c3bb26d8c96d2c526d24102d11fab39e7043722dbd64f32848fbc277cda7699e76334fa73afff8adba54
diff --git a/dev-python/oslo-policy/oslo-policy-3.1.0.ebuild b/dev-python/oslo-policy/oslo-policy-3.1.0.ebuild
new file mode 100644
index 000000000000..6f8fabf2b9bf
--- /dev/null
+++ b/dev-python/oslo-policy/oslo-policy-3.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Support for RBAC policy enforcement across all OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.policy/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.policy/oslo.policy-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.22.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-1.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-1.19.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.40.0[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/oslo.policy-${PV}"