summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-10-16 00:21:40 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2015-10-16 00:24:24 -0500
commit0bca3deef8d1458f71499b559200b8302c5fdcf1 (patch)
treed547fe3a6b7f9a2479f02b260ead80f97d4ec86b /dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild
parentdev-python/oslo-reports: actually liberty this time (diff)
downloadgentoo-0bca3deef8d1458f71499b559200b8302c5fdcf1.tar.gz
gentoo-0bca3deef8d1458f71499b559200b8302c5fdcf1.tar.bz2
gentoo-0bca3deef8d1458f71499b559200b8302c5fdcf1.zip
dev-python/oslo-rootwrap: actually liberty now
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild')
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild
new file mode 100644
index 000000000000..2087ae7b6a14
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-2.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo Rootwrap allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.17.4[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}