summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-11-04 10:19:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-11-04 10:19:29 -0500
commit93d432168da6915fc21f2e223f1971cd15522703 (patch)
tree9d42e69edf9c5c884e9c1ebd4363cf3a93fc970d /dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild
parentsys-cluster/heat: fix CVE-2016-9185 bug 598940 (diff)
downloadgentoo-93d432168da6915fc21f2e223f1971cd15522703.tar.gz
gentoo-93d432168da6915fc21f2e223f1971cd15522703.tar.bz2
gentoo-93d432168da6915fc21f2e223f1971cd15522703.zip
dev-python/oslo-rootwrap: bup
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild')
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild
new file mode 100644
index 000000000000..d3093616b124
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}