summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-02-26 21:30:20 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2017-02-26 22:26:04 -0600
commit68037f22f8df6fc7e1b0183f30e7d05cad115acd (patch)
tree53406148c8da96a5c9dfa45887de37ba105ea27b /dev-python/oslo-rootwrap
parentdev-python/oslo-reports: bup (diff)
downloadgentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.tar.gz
gentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.tar.bz2
gentoo-68037f22f8df6fc7e1b0183f30e7d05cad115acd.zip
dev-python/oslo-rootwrap: bup
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest1
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index f14843f76e95..2364d30a0b5f 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1,2 +1,3 @@
DIST oslo.rootwrap-4.1.0.tar.gz 35590 SHA256 083b6255228982484fc483db845a49e07f474cfc12ba1ba70490f56880027989 SHA512 ef06507989d168bed8d3943d69c53318b87a2de6f403b9563d79ca75b9e17da887ce68775c54cc0fb8488e99ae3dccb08f8c3e4cf2d46882b699625519a46705 WHIRLPOOL 638a8cbf3cf463067ddc26934b914d4bf50b7b6ce51ba48a83df7abcad62836a1bdb0f660120a04facf4d1cfec589bb690a7039486884cbf3013e1ab622f9dd1
DIST oslo.rootwrap-5.1.1.tar.gz 35982 SHA256 b48a3a5eeec533b4d450cd811a36a99e9d6f9e5316359285663318703c80d5b3 SHA512 1f50316529340b8dd2718c1ae84da263bbdfd899df31c3e30fcc122a2c857f21bb5844f6ab6a7b6d668931008237bde1652fc8fe066566eae26b80fb7d726f3d WHIRLPOOL 9720f1709ba7f13d141137f9a60c5fb976956c5d3e3055972c82d43b002a932d67d2e8589a64f9a999a2f22267b4984bac8d0dcb37890d3c0f2cf442aa52c274
+DIST oslo.rootwrap-5.4.0.tar.gz 40741 SHA256 8b3c1c5726e0845fcd00d9f951f012bdd3405380acf125428268fba4f70f3c00 SHA512 9848d9f18b7a4063f74d170615b99dc3ebcbcba1ff1f0a10f42b2af9284dd58a65a6b483bed20d176de00170ad60ac7b847cf5a31b950fcd7bf06ecbaecb1823 WHIRLPOOL 0996255270825040156767ae1b08a82aa8df87cabd9122522866ce38e99278c72242d1dfae5e0417267d1dd683b5e3d4ba0d3dcbc75e4449df2a01b267ea24b2
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild
new file mode 100644
index 000000000000..42e6fb2940bd
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.4.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.2.1[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-4.7.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}