summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-25 17:25:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-25 17:25:35 -0500
commita8831228fb560b555f1c82801fd1b37bcbaacbba (patch)
treeb718ef601fe70913f2b9d3db15afec8fdaa22de3 /dev-python/oslo-rootwrap
parentdev-python/oslo-reports: bup for mitaka (diff)
downloadgentoo-a8831228fb560b555f1c82801fd1b37bcbaacbba.tar.gz
gentoo-a8831228fb560b555f1c82801fd1b37bcbaacbba.tar.bz2
gentoo-a8831228fb560b555f1c82801fd1b37bcbaacbba.zip
dev-python/oslo-rootwrap: bup for mitaka
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest1
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-4.1.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index 1b23cbc79f88..6e5ef7df4f47 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -3,3 +3,4 @@ DIST oslo.rootwrap-1.3.0.tar.gz 37576 SHA256 42081a30779be0a8e33ee53f4e1235c1708
DIST oslo.rootwrap-1.6.0.tar.gz 48419 SHA256 5fe6d1619a5306f9181899c7cc5251ba5a0de0d3c60f85b2172a2f7d400a4962 SHA512 89f6615f87e9d45e7810157a07df3f8ceeab5f7b6826bc16256294eb9c6031cf6c5c698d92816f31e160d1f5bb98b7564cbf54079b0370ec47b9dbe83c3c2b0f WHIRLPOOL 4109b2e393b41c70e7e94f9f71674b6ea8dc6ae369cfe094f31a3372d049355f690f5bcf2a90804b5f1a0d02560d798471b855c39fcea3b5a577b1f86fba8f10
DIST oslo.rootwrap-2.3.0.tar.gz 41367 SHA256 2ce6483fee2955f2462b529682a7afb95c6bd745038f69ff408bde9004b83a87 SHA512 6add1d88e13100f11a5e8faee76a1a42f1113dad55dd530bd923714d53beeb7007f8e37c24a12debb9db3fa81fad8b8d363ac463535b367134e93e753c9ef2a7 WHIRLPOOL b3eb54a7a0be5d59825f4d019849dc75e8d94659f47965c921d6d85215a882f79bdd3785f9f7bcab35878219053705428e5c68c64dc78d1b9a5bdf11f027672c
DIST oslo.rootwrap-2.4.0.tar.gz 35568 SHA256 a5ad4ab3379e29db324db93fbfa405501978c7ac582d18cb31fcc7e92bcd219c SHA512 e9ebce080fad9a5c862602ab78108c4f22bc9988dce2a774614f8223b430a0fdc3a50573eac468dbf3c1a2d178dd372c51e3e30aa3a0ed3a799b6253676eb6e1 WHIRLPOOL 95652554eaf4d5b94d9cc949ed435e81819985b42a8a1016f3d43bbb46406353c0fb8f642a7e7bf8b483f7b211a5480d54660fc2d44753417e66e5b0af3d2e6e
+DIST oslo.rootwrap-4.1.0.tar.gz 35590 SHA256 083b6255228982484fc483db845a49e07f474cfc12ba1ba70490f56880027989 SHA512 ef06507989d168bed8d3943d69c53318b87a2de6f403b9563d79ca75b9e17da887ce68775c54cc0fb8488e99ae3dccb08f8c3e4cf2d46882b699625519a46705 WHIRLPOOL 638a8cbf3cf463067ddc26934b914d4bf50b7b6ce51ba48a83df7abcad62836a1bdb0f660120a04facf4d1cfec589bb690a7039486884cbf3013e1ab622f9dd1
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-4.1.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-4.1.0.ebuild
new file mode 100644
index 000000000000..e2c0b44677aa
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-4.1.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo Rootwrap allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-sphinx-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}