summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@gentoo.org>2015-11-14 19:36:32 -0600
committerAlex Brandt <alunduil@gentoo.org>2015-11-14 19:36:32 -0600
commit98d73d600743a8d49a3454959e9fa64135abf115 (patch)
treee1887ce6615949f633f88448daf2bc9c87cc5b02 /dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild
parentdev-scheme/chicken: cleanup; rm vn. 4.10.0-r1 wrt the gentoo bug (diff)
downloadgentoo-98d73d600743a8d49a3454959e9fa64135abf115.tar.gz
gentoo-98d73d600743a8d49a3454959e9fa64135abf115.tar.bz2
gentoo-98d73d600743a8d49a3454959e9fa64135abf115.zip
dev-python/oslo-serialization: add version 1.11.0
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild')
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild75
1 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild b/dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild
new file mode 100644
index 000000000000..e173eaa637c9
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-1.11.0.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-serialization/oslo-serialization-1.5.0.ebuild,v 1.1 2015/04/22 20:04:44 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-1.2[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.12[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/simplejson-2.2.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslo-sphinx-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}