summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-29 16:42:45 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-29 22:43:40 -0500
commit19adfded88fa698aa49dd5310b231e9cb57a3ff5 (patch)
tree1f7c14336a06f1350c52b08df7a9d1c9e3cbf612 /dev-python/osprofiler
parentsci-libs/blas-reference: ebuild maintenance, cleanup (diff)
downloadgentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.gz
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.tar.bz2
gentoo-19adfded88fa698aa49dd5310b231e9cb57a3ff5.zip
add initial support for newton (keystone)
dropped py3.3 and updated most (maybe all) to eapi6
Diffstat (limited to 'dev-python/osprofiler')
-rw-r--r--dev-python/osprofiler/Manifest1
-rw-r--r--dev-python/osprofiler/osprofiler-1.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/osprofiler/Manifest b/dev-python/osprofiler/Manifest
index 71d15e52c418..b9772120b13a 100644
--- a/dev-python/osprofiler/Manifest
+++ b/dev-python/osprofiler/Manifest
@@ -1 +1,2 @@
DIST osprofiler-1.2.0.tar.gz 53375 SHA256 62447e1ed954587036e1fa62b9f7d5f9d23b585f6fd0bf7a4c3b7926880f7f0d SHA512 4c7d9ac8ed447e5b6bf8dabd37a144dad21c176e42abd20348a6f3fe2eccc9f05fa88aa04e63ea730bc9acd52c69a2949b39535363ba47e5b6ad96804fb3c0c5 WHIRLPOOL bee27edabea3ab48b742a0e220f26dc8d4595dc244ed676e402af81096daf533a2fea42ca89a3963d2d8d4eb5dba2e9e23edb8caca2b1c0eccb39956c7a82a8d
+DIST osprofiler-1.4.0.tar.gz 59906 SHA256 cda53436ffc8fc155fd220dd9bc9b2819c89f35baf62cd85f68dd5ea900f33fc SHA512 541f51b949158d7ce5ff31c8d5632a57ce557469e3277d9aae1c589377388e9f57a7abcd436c4452af544ba3d4dd3332e43b8e3594e7aa13a526f0d24360c176 WHIRLPOOL d7f7d2f5d8fd2b09d8e047f69809b7e1e21c8c2276a0a316132db47c5e18430bc866caa2fe3812173c175c1b3076c385226173eb81bb06712e0bdb50a5a2c099
diff --git a/dev-python/osprofiler/osprofiler-1.4.0.ebuild b/dev-python/osprofiler/osprofiler-1.4.0.ebuild
new file mode 100644
index 000000000000..a7d059bf0db8
--- /dev/null
+++ b/dev-python/osprofiler/osprofiler-1.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Profiler Library"
+HOMEPAGE="https://launchpad.net/osprofiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+"