summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:01:38 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-26 23:25:23 -0500
commit754c0d1a1d1d28011421c74a0afc856a2fc70499 (patch)
tree33ab53910b94ada53791b93d88642475559e056e /dev-python/osprofiler
parentdev-python/pycadf: 2.6.0 bup2.6.0 bup (diff)
downloadgentoo-754c0d1a1d1d28011421c74a0afc856a2fc70499.tar.gz
gentoo-754c0d1a1d1d28011421c74a0afc856a2fc70499.tar.bz2
gentoo-754c0d1a1d1d28011421c74a0afc856a2fc70499.zip
dev-python/osprofiler: 1.11.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/osprofiler')
-rw-r--r--dev-python/osprofiler/Manifest1
-rw-r--r--dev-python/osprofiler/osprofiler-1.11.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/osprofiler/Manifest b/dev-python/osprofiler/Manifest
index 614e71f102b1..5913d35fd42a 100644
--- a/dev-python/osprofiler/Manifest
+++ b/dev-python/osprofiler/Manifest
@@ -1,3 +1,4 @@
+DIST osprofiler-1.11.0.tar.gz 75301 SHA256 b79081344555e0c7ba6fdd02a774e81728cbe81d82d8bfbe201ebd72899e6132 SHA512 41697a9d3bfb81f0c193bd1bd82cb470f1e7e410192e982c076877026457c9b7eb3d17b72c3d02ba4e1bda6ff4a7006798210f37c67d75ff600e41fa047ca59e WHIRLPOOL 24616173f4f9e5f14ed4a5ea7a5de4fb8a9165ae663c5f2ce8ac73964fb876f08b938b2e73711c7b9499ca6f17baf4cced821270433c4293385a4cbab60ba930
DIST osprofiler-1.2.0.tar.gz 53375 SHA256 62447e1ed954587036e1fa62b9f7d5f9d23b585f6fd0bf7a4c3b7926880f7f0d SHA512 4c7d9ac8ed447e5b6bf8dabd37a144dad21c176e42abd20348a6f3fe2eccc9f05fa88aa04e63ea730bc9acd52c69a2949b39535363ba47e5b6ad96804fb3c0c5 WHIRLPOOL bee27edabea3ab48b742a0e220f26dc8d4595dc244ed676e402af81096daf533a2fea42ca89a3963d2d8d4eb5dba2e9e23edb8caca2b1c0eccb39956c7a82a8d
DIST osprofiler-1.4.0.tar.gz 59906 SHA256 cda53436ffc8fc155fd220dd9bc9b2819c89f35baf62cd85f68dd5ea900f33fc SHA512 541f51b949158d7ce5ff31c8d5632a57ce557469e3277d9aae1c589377388e9f57a7abcd436c4452af544ba3d4dd3332e43b8e3594e7aa13a526f0d24360c176 WHIRLPOOL d7f7d2f5d8fd2b09d8e047f69809b7e1e21c8c2276a0a316132db47c5e18430bc866caa2fe3812173c175c1b3076c385226173eb81bb06712e0bdb50a5a2c099
DIST osprofiler-1.5.0.tar.gz 72539 SHA256 aee63cfd888e6049ea82535ce458ce4844b4ac893dcb18060eda24192505627e SHA512 a4adaf39e4680d5d7d729b27c578919b335209671f911138e135c7554f0af33dce25e46863e65f98a2022a534e0f93c77acbc3bc69d304a28aa846fb5dbf469c WHIRLPOOL c0d55a6ce5db495bf02f619287987dd148ff5e83cbfc1a2b91893a05ff619c5806a02eaa87a3b1c83225699de84fd0f3e0b623fe664e9a0ead5c37eef99aac81
diff --git a/dev-python/osprofiler/osprofiler-1.11.0.ebuild b/dev-python/osprofiler/osprofiler-1.11.0.ebuild
new file mode 100644
index 000000000000..1f158dae1a79
--- /dev/null
+++ b/dev-python/osprofiler/osprofiler-1.11.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenStack Profiler Library"
+HOMEPAGE="https://launchpad.net/osprofiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/pbr-1.8.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.16.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
+ !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
+ >=dev-python/oslo-concurrency-3.8.0[${PYTHON_USEDEP}]
+"