summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-05-05 10:25:51 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-05-05 10:25:51 +0300
commit41058480dd2de8d25b5ab6055543cd5ed4b23a54 (patch)
tree2eeda7b0103ea319feed2c59079d0d8e7de39415 /dev-python/ovs
parentdev-python/autobahn: add 22.4.2 (diff)
downloadgentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.tar.gz
gentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.tar.bz2
gentoo-41058480dd2de8d25b5ab6055543cd5ed4b23a54.zip
dev-python/ovs: add 2.17.1_p1, enable py3.10, cleanup
Closes: https://bugs.gentoo.org/841569 Closes: https://bugs.gentoo.org/722582 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/ovs')
-rw-r--r--dev-python/ovs/Manifest1
-rw-r--r--dev-python/ovs/ovs-2.17.1_p1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/ovs/Manifest b/dev-python/ovs/Manifest
index 2d96592bd0aa..92b4eaa75be2 100644
--- a/dev-python/ovs/Manifest
+++ b/dev-python/ovs/Manifest
@@ -1,2 +1,3 @@
DIST ovs-2.13.0.tar.gz 100450 BLAKE2B 943486bf0aad0e8e9eac96c85aeccb32fd36c60689623acc76175eafc286f4689142d6ea6953224e0a4ea8e4437c56738cb5b113286114de0898bf783cd49668 SHA512 7ec8980257ae87d24dbabc5900cf81253490bcfa0431f96b79280603da04a972fc536055bf532d2b251e03e007b49b34e8118b0f323e5fee05c116824d68562c
DIST ovs-2.13.3.tar.gz 102736 BLAKE2B ee6f10a41bf46534d3963360a63a0a39a7ffbed6de468894c566c7dd2ee0c645cf6f8f211bfbcda70f03b4204e396fc0b081f457df9d27f93fc40d158bb641b8 SHA512 9f73dc383f7b717000d6d1f8f2f9114ee2be2457c9b352de68c01c1f9075c39ab4a9ef14fe67083bf1da1872240204eb2642fbf7b5a871a5ad044191e0774d88
+DIST ovs-2.17.1.post1.tar.gz 104766 BLAKE2B e1cb471f7f3f3b8461292c79ee5318a36d70c2ee55947bfa0274277e36514d20ad9293cb8c602e0b2c82a590397869fe51f52ee2579255bb8163014d58dccaf7 SHA512 772e7b4768f1e7fe1f2be700a0eb6bc539459e4c70432c45e7f7877b060f4c845eaa5a974f2b2264af621f5f43b97da30a9fe344a53904ec0008393689e6b895
diff --git a/dev-python/ovs/ovs-2.17.1_p1.ebuild b/dev-python/ovs/ovs-2.17.1_p1.ebuild
new file mode 100644
index 000000000000..f0cef5068684
--- /dev/null
+++ b/dev-python/ovs/ovs-2.17.1_p1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=${P/_p/.post}
+
+DESCRIPTION="OVS bindings for python"
+HOMEPAGE="https://github.com/openvswitch/ovs/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/sortedcontainers[${PYTHON_USEDEP}]"