summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-01-20 16:35:44 +0100
committerJustin Lecher <jlec@gentoo.org>2016-01-20 16:36:43 +0100
commitf57348fc2434e88d1264f454a954ad45d1297897 (patch)
treef1662d1918fef8039d75325c6a079250f5268f6e /dev-python/packaging/packaging-16.0.ebuild
parentnet-im/gajim: Drop version vulnerable to CVE-2015-8688 (diff)
downloadgentoo-f57348fc2434e88d1264f454a954ad45d1297897.tar.gz
gentoo-f57348fc2434e88d1264f454a954ad45d1297897.tar.bz2
gentoo-f57348fc2434e88d1264f454a954ad45d1297897.zip
dev-python/packaging: Version Bump
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/packaging/packaging-16.0.ebuild')
-rw-r--r--dev-python/packaging/packaging-16.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/packaging/packaging-16.0.ebuild b/dev-python/packaging/packaging-16.0.ebuild
new file mode 100644
index 000000000000..5bbc7fa32eb8
--- /dev/null
+++ b/dev-python/packaging/packaging-16.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Core utilities for Python packages"
+HOMEPAGE="https://github.com/pypa/packaging https://pypi.python.org/pypi/packaging"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="|| ( Apache-2.0 BSD-2 )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test --capture=no --strict -v || die
+}
+
+pkg_preinst() {
+ # Remove this in the next version bump
+ _cleanup() {
+ local pyver=$("${PYTHON}" -c "from distutils.sysconfig import get_python_version; print(get_python_version())")
+ local egginfo="${ROOT%/}$(python_get_sitedir)/${P}-py${pyver}.egg-info"
+ if [[ -d ${egginfo} ]]; then
+ echo rm -r "${egginfo}"
+ rm -r "${egginfo}" || die "Failed to remove egg-info directory"
+ fi
+ }
+ python_foreach_impl _cleanup
+}