summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLucas Ramage <ramage.lucas@protonmail.com>2018-09-22 15:27:03 -0400
committerVirgil Dupras <vdupras@gentoo.org>2018-10-18 07:33:18 -0400
commit3282dc2a83ca47c061c8a9f3176e595837171922 (patch)
treee4bbb2a69f9a1e991618ea782dab1ce18705101b /dev-python/paho-mqtt
parentnet-vpn/strongswan: x86 stable (bug #668862) (diff)
downloadgentoo-3282dc2a83ca47c061c8a9f3176e595837171922.tar.gz
gentoo-3282dc2a83ca47c061c8a9f3176e595837171922.tar.bz2
gentoo-3282dc2a83ca47c061c8a9f3176e595837171922.zip
dev-python/paho-mqtt: bump version to 1.4.0
Signed-off-by: Lucas Ramage <ramage.lucas@protonmail.com> Closes: https://bugs.gentoo.org/665148 Package-Manager: Portage-2.3.24, Repoman-2.3.6 Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Diffstat (limited to 'dev-python/paho-mqtt')
-rw-r--r--dev-python/paho-mqtt/Manifest1
-rw-r--r--dev-python/paho-mqtt/metadata.xml2
-rw-r--r--dev-python/paho-mqtt/paho-mqtt-1.4.0.ebuild37
3 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/paho-mqtt/Manifest b/dev-python/paho-mqtt/Manifest
index 6897f7cabd5b..e99383d9cbf8 100644
--- a/dev-python/paho-mqtt/Manifest
+++ b/dev-python/paho-mqtt/Manifest
@@ -1,2 +1,3 @@
DIST paho-mqtt-1.1.zip 159529 BLAKE2B ca3a39628c9cab8c4f3606587a5c853e79535b37a92991ecc32903967952cc00f6a9b967af0d343c4619f3e46ace1330baebc7c2e9dc231673f51775e4e1de25 SHA512 ef6d1a29480671413dbb655bd8f668b99f8587c14589d2180a37142b368e0ce058f8ed967dbfaa82f239c86e295338bc35c9f28a3ea39d21a6034cd8787a63ce
DIST paho-mqtt-1.3.1.tar.gz 102133 BLAKE2B 905a51824d487cb125e06114bcba6b1ba862de4ab816db16aadb6ff761145fd4724dc6523a0c6837b8a16ced6730c5558612deb138bd95721f15054f5d6851a4 SHA512 95adeeaffbbd4b39d19fbd46feb39ec4a2ac923addd3c754a474b7a91d620bfca1678645c1a09c925e38a33995575944b873e3b2300d7bc2f3c5be3005c74d4c
+DIST paho-mqtt-1.4.0.tar.gz 108278 BLAKE2B 0569f3cb5d262b3b7f6ae68261fe138d839afcc6fe91f880e29de24d5cf8e2491af81a30eb82c27fe63eee90114326eb75b06a32e05ec2fffed27b92d9601902 SHA512 2e49f0f146207ab4fbc8c346b10d3e2b50869b2d9db7c999b6645f7213fb635b64cff01c5405e7833a8b25334d24685ce6ed734a6e4b6b0660b48f65cf4a941c
diff --git a/dev-python/paho-mqtt/metadata.xml b/dev-python/paho-mqtt/metadata.xml
index c1efb3bd1df1..87bf6367c9c2 100644
--- a/dev-python/paho-mqtt/metadata.xml
+++ b/dev-python/paho-mqtt/metadata.xml
@@ -2,7 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
- <email>ramage.lucas@openmailbox.org</email>
+ <email>ramage.lucas@protonmail.com</email>
<name>Lucas Ramage</name>
</maintainer>
<maintainer type="project">
diff --git a/dev-python/paho-mqtt/paho-mqtt-1.4.0.ebuild b/dev-python/paho-mqtt/paho-mqtt-1.4.0.ebuild
new file mode 100644
index 000000000000..3f9c95cc4cd4
--- /dev/null
+++ b/dev-python/paho-mqtt/paho-mqtt-1.4.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="A client class with support for both MQTT v3.1 and v3.1.1"
+HOMEPAGE="https://www.eclipse.org/paho/clients/python/"
+SRC_URI="https://github.com/eclipse/paho.mqtt.python/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ ) "
+
+S="${WORKDIR}/paho.mqtt.python-${PV}"
+
+RESTRICT="test" #659106
+
+src_prepare() {
+ eapply "${FILESDIR}/${PN}-1.3.1-strip-test-dependency.patch"
+ default
+}
+
+python_test() {
+ esetup.py test
+}