summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/paisley
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/paisley')
-rw-r--r--dev-python/paisley/Manifest1
-rw-r--r--dev-python/paisley/metadata.xml9
-rw-r--r--dev-python/paisley/paisley-0.3.1-r1.ebuild27
-rw-r--r--dev-python/paisley/paisley-0.3.1.ebuild25
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/paisley/Manifest b/dev-python/paisley/Manifest
new file mode 100644
index 000000000000..624a602f61a3
--- /dev/null
+++ b/dev-python/paisley/Manifest
@@ -0,0 +1 @@
+DIST paisley-0.3.1.tar.gz 6373 SHA256 531767b266c82e72d7f58e91b8e8093da6d227c779069894b50253f1fad280a3 SHA512 abfceece7c3156fd3ed234e1c2ed07e8f3e366c735969e382feb3b8c464679d8a9f0a224be0720c351b3e19d576bb5aff6fc11d789bfd879a0f2aba40dfaef73 WHIRLPOOL fe4955aebadf9a508210f55b2a20c47bf5af974949fd1cec1d7192a7f109ae089ed336dd86e8c839dfb5a29a0b455d4268e655ccbc706458857b95e6980fd2e1
diff --git a/dev-python/paisley/metadata.xml b/dev-python/paisley/metadata.xml
new file mode 100644
index 000000000000..ead40ea006d1
--- /dev/null
+++ b/dev-python/paisley/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">paisley</remote-id>
+ <remote-id type="launchpad">paisley</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/paisley/paisley-0.3.1-r1.ebuild b/dev-python/paisley/paisley-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..a83a2687f239
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application"
+HOMEPAGE="http://launchpad.net/paisley http://pypi.python.org/pypi/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ nosetests || die "tests failed"
+}
diff --git a/dev-python/paisley/paisley-0.3.1.ebuild b/dev-python/paisley/paisley-0.3.1.ebuild
new file mode 100644
index 000000000000..cbdf944435f3
--- /dev/null
+++ b/dev-python/paisley/paisley-0.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+DISTUTILS_SRC_TEST="nosetests"
+
+inherit distutils
+
+DESCRIPTION="Paisley is a CouchDB client written in Python to be used within a Twisted application"
+HOMEPAGE="http://launchpad.net/paisley http://pypi.python.org/pypi/paisley"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="dev-python/simplejson
+ dev-python/twisted-core
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}"