summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-18 15:17:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-18 15:33:51 +0100
commit2627cdfaa51b7599a611c91edde13b1ac651a9cd (patch)
tree579514344a6b4ff06562d9ab92734a1ccb0a5821 /dev-python/pandas
parentdev-python/ansi2html: 1.6.0 (diff)
downloadgentoo-2627cdfaa51b7599a611c91edde13b1ac651a9cd.tar.gz
gentoo-2627cdfaa51b7599a611c91edde13b1ac651a9cd.tar.bz2
gentoo-2627cdfaa51b7599a611c91edde13b1ac651a9cd.zip
dev-python/pandas: Remove (optional) dep on dev-python/s3fs
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pandas')
-rw-r--r--dev-python/pandas/pandas-1.0.5-r1.ebuild (renamed from dev-python/pandas/pandas-1.0.5.ebuild)2
-rw-r--r--dev-python/pandas/pandas-1.1.2-r1.ebuild (renamed from dev-python/pandas/pandas-1.1.2.ebuild)2
-rw-r--r--dev-python/pandas/pandas-1.1.4-r1.ebuild (renamed from dev-python/pandas/pandas-1.1.4.ebuild)2
3 files changed, 0 insertions, 6 deletions
diff --git a/dev-python/pandas/pandas-1.0.5.ebuild b/dev-python/pandas/pandas-1.0.5-r1.ebuild
index ed65359d2c39..05ab931fc714 100644
--- a/dev-python/pandas/pandas-1.0.5.ebuild
+++ b/dev-python/pandas/pandas-1.0.5-r1.ebuild
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
dev-python/xlsxwriter[${PYTHON_USEDEP}]
)
>=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
- dev-python/s3fs[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
@@ -162,7 +161,6 @@ pkg_postinst() {
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
- optfeature "necessary for Amazon S3 access" dev-python/s3fs
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
diff --git a/dev-python/pandas/pandas-1.1.2.ebuild b/dev-python/pandas/pandas-1.1.2-r1.ebuild
index 347189e62999..5bf55696819f 100644
--- a/dev-python/pandas/pandas-1.1.2.ebuild
+++ b/dev-python/pandas/pandas-1.1.2-r1.ebuild
@@ -42,7 +42,6 @@ OPTIONAL_DEPEND="
dev-python/xlsxwriter[${PYTHON_USEDEP}]
)
>=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
- dev-python/s3fs[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
@@ -168,7 +167,6 @@ pkg_postinst() {
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
- optfeature "necessary for Amazon S3 access" dev-python/s3fs
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt
diff --git a/dev-python/pandas/pandas-1.1.4.ebuild b/dev-python/pandas/pandas-1.1.4-r1.ebuild
index db6f0cd767d9..ec902a8752af 100644
--- a/dev-python/pandas/pandas-1.1.4.ebuild
+++ b/dev-python/pandas/pandas-1.1.4-r1.ebuild
@@ -41,7 +41,6 @@ OPTIONAL_DEPEND="
dev-python/xlsxwriter[${PYTHON_USEDEP}]
)
>=dev-python/pytables-3.2.1[${PYTHON_USEDEP}]
- dev-python/s3fs[${PYTHON_USEDEP}]
dev-python/statsmodels[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/xarray-0.10.8[${PYTHON_USEDEP}]
@@ -167,7 +166,6 @@ pkg_postinst() {
optfeature "accelerating certain numerical operations, using multiple cores as well as smart chunking and caching to achieve large speedups" ">=dev-python/numexpr-2.1"
optfeature "needed for pandas.io.html.read_html" dev-python/beautifulsoup:4 dev-python/html5lib dev-python/lxml
optfeature "for msgpack compression using blosc" dev-python/blosc
- optfeature "necessary for Amazon S3 access" dev-python/s3fs
optfeature "Template engine for conditional HTML formatting" dev-python/jinja
optfeature "Plotting support" dev-python/matplotlib
optfeature "Needed for Excel I/O" ">=dev-python/openpyxl-1.6.1" dev-python/xlsxwriter dev-python/xlrd dev-python/xlwt