summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-04 05:30:48 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-04 05:30:48 +0100
commit67095de4eae0fe705da6609d9cc31adebb2a49dd (patch)
treeb9260a5839dbc4a5a6266b0a66ea541fda58a573 /dev-python/parso/parso-0.6.1.ebuild
parentapp-emulation/wine-staging: Sync with ::wine (diff)
downloadgentoo-67095de4eae0fe705da6609d9cc31adebb2a49dd.tar.gz
gentoo-67095de4eae0fe705da6609d9cc31adebb2a49dd.tar.bz2
gentoo-67095de4eae0fe705da6609d9cc31adebb2a49dd.zip
dev-python/parso: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso/parso-0.6.1.ebuild')
-rw-r--r--dev-python/parso/parso-0.6.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/parso/parso-0.6.1.ebuild b/dev-python/parso/parso-0.6.1.ebuild
new file mode 100644
index 000000000000..d33ced31acc5
--- /dev/null
+++ b/dev-python/parso/parso-0.6.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest