summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-07 06:37:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-07 06:37:51 +0200
commit590283e189d539f8ba51d6535026cb2217714614 (patch)
tree2c0720a944e83842d088fa6c6f4af38d4d7b40d3 /dev-python/parso
parentdev-python/backcall: Enable pypy3 (diff)
downloadgentoo-590283e189d539f8ba51d6535026cb2217714614.tar.gz
gentoo-590283e189d539f8ba51d6535026cb2217714614.tar.bz2
gentoo-590283e189d539f8ba51d6535026cb2217714614.zip
dev-python/parso: Switch to PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/parso-0.8.3-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/parso/parso-0.8.3-r1.ebuild b/dev-python/parso/parso-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..e2527b1ee829
--- /dev/null
+++ b/dev-python/parso/parso-0.8.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="
+ https://github.com/davidhalter/parso/
+ https://pypi.org/project/parso/
+"
+SRC_URI="
+ https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # py3.10 changed exception messages
+ test/test_python_errors.py::test_python_exception_matches
+)