summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-08-29 22:12:53 +0200
committerMichał Górny <mgorny@gentoo.org>2018-08-30 17:02:42 +0200
commit5dc5deb92c2091d085b7c7af227bc33432a50627 (patch)
treec24ed34c4294276bf63384813c3dfec783db426a /dev-python/parso
parentsci-libs/xdmf2: Fix build with CMake 3.12+ (diff)
downloadgentoo-5dc5deb92c2091d085b7c7af227bc33432a50627.tar.gz
gentoo-5dc5deb92c2091d085b7c7af227bc33432a50627.tar.bz2
gentoo-5dc5deb92c2091d085b7c7af227bc33432a50627.zip
dev-python/parso: Bump to 0.3.1
Diffstat (limited to 'dev-python/parso')
-rw-r--r--dev-python/parso/Manifest1
-rw-r--r--dev-python/parso/parso-0.3.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/parso/Manifest b/dev-python/parso/Manifest
index 653c03656952..743749da4917 100644
--- a/dev-python/parso/Manifest
+++ b/dev-python/parso/Manifest
@@ -1 +1,2 @@
DIST parso-0.1.1.tar.gz 376876 BLAKE2B ad0b9492273d23da1f4133a2f1e6edd2fa7f2213dbe12868f891863e9286fa0281de7fc6c6924b78a5820f94867971bbc09f18b3d0f2e4832c9c875850205254 SHA512 1199651136af1c9f0801a031a197e367f7fa73b5878b863103a506481e8b325e6b305e4260510a567dccf91f298fd7e9e5674f4dc410765ae1f9112f742aa6a0
+DIST parso-0.3.1.tar.gz 375226 BLAKE2B 71481f5f382f14e5f2c7826f8eb50a1c35f8c280f14c8bf52bcf44f77aa9872cddce7d7fb7b0a586ab7cda547e43bbce11812077ae84129c418a9f0bb3c5b856 SHA512 f83e316a41e21d3132d9ee8a45f9042962c01a2b906e8791046112b9ed938d378b0dc28c4ae05ce03a8c2d19563a49cba9a9a230654345ff62e87cc763536ddb
diff --git a/dev-python/parso/parso-0.3.1.ebuild b/dev-python/parso/parso-0.3.1.ebuild
new file mode 100644
index 000000000000..158e3a277f6a
--- /dev/null
+++ b/dev-python/parso/parso-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ppc64 x86"
+IUSE="doc test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -vv test || die "tests failed with ${EPYTHON}"
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}