summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-11 22:07:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-11 22:07:17 +0200
commit38d8c5124010283bf4b8f7801350ef4e2ccc2aff (patch)
tree9b96e56bb2bff9662f8091086663cd4e9e5dc3f3 /dev-python/paste
parentdev-python/manuel: EAPI 8, PEP517 (diff)
downloadgentoo-38d8c5124010283bf4b8f7801350ef4e2ccc2aff.tar.gz
gentoo-38d8c5124010283bf4b8f7801350ef4e2ccc2aff.tar.bz2
gentoo-38d8c5124010283bf4b8f7801350ef4e2ccc2aff.zip
dev-python/paste: EAPI 8, PEP517, rm namespace dep
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/paste')
-rw-r--r--dev-python/paste/paste-3.5.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/paste/paste-3.5.0-r1.ebuild b/dev-python/paste/paste-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..243ab2deafcf
--- /dev/null
+++ b/dev-python/paste/paste-3.5.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P="Paste-${PV}"
+DESCRIPTION="Tools for using a Web Server Gateway Interface stack"
+HOMEPAGE="https://pypi.org/project/Paste/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~sparc-solaris"
+
+RDEPEND="
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/test_proxy.py
+)
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}