summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-11-27 12:01:55 -0800
committerPatrick McLean <chutzpah@gentoo.org>2019-11-27 13:19:26 -0800
commit137e37864644137c8f8d8ab950c487c83d36c54f (patch)
tree7fb2555799b1ed5f00320adfb161821a97b9a173 /dev-python/pastedeploy
parentdev-python/paste-3.2.3: Bump, add py38 and pypy{,3} (diff)
downloadgentoo-137e37864644137c8f8d8ab950c487c83d36c54f.tar.gz
gentoo-137e37864644137c8f8d8ab950c487c83d36c54f.tar.bz2
gentoo-137e37864644137c8f8d8ab950c487c83d36c54f.zip
dev-python/pastedeploy-2.0.1-r1: revbump, add py38 and pypy{,3}
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/pastedeploy')
-rw-r--r--dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild b/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..016dda41de95
--- /dev/null
+++ b/dev-python/pastedeploy/pastedeploy-2.0.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy{,3} )
+
+inherit distutils-r1
+
+MY_PN="PasteDeploy"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Load, configure, and compose WSGI applications and servers"
+HOMEPAGE="https://pypi.org/project/PasteDeploy/"
+# pypi tarball does not include tests
+SRC_URI="https://github.com/Pylons/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="doc"
+
+RDEPEND="dev-python/namespace-paste[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+BDEPEND="${RDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i 's:"pytest-runner"::' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ use doc && dodoc docs/*.txt
+ find "${D}" -name '*.pth' -delete || die
+}