summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-08-17 19:22:21 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-08-21 10:28:53 +0200
commit85eafb6370f8baa6119d63308ddb89267f4f4ea5 (patch)
tree26c1514d5c3ae98cb47cd7bfc2033732e797961d /dev-python/paver/paver-1.3.4.ebuild
parentdev-python/jsmin: version bump. (diff)
downloadgentoo-85eafb6370f8baa6119d63308ddb89267f4f4ea5.tar.gz
gentoo-85eafb6370f8baa6119d63308ddb89267f4f4ea5.tar.bz2
gentoo-85eafb6370f8baa6119d63308ddb89267f4f4ea5.zip
dev-python/paver: version bump.
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-python/paver/paver-1.3.4.ebuild')
-rw-r--r--dev-python/paver/paver-1.3.4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/paver/paver-1.3.4.ebuild b/dev-python/paver/paver-1.3.4.ebuild
new file mode 100644
index 000000000000..addd2dd324bf
--- /dev/null
+++ b/dev-python/paver/paver-1.3.4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+MY_PN=${PN/p/P}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python-based software project scripting tool along the lines of Make"
+HOMEPAGE="http://www.blueskyonmars.com/projects/paver/ https://github.com/paver/paver"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ # https://github.com/paver/paver/issues/143#issuecomment-103943327
+ find paver/tests -name '*.pyc' -delete || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}