summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-09-11 12:39:52 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-09-11 19:06:32 -0500
commit083f371f720dcfbddc292f5f172e31d62c66552a (patch)
treeaf48d5aca86d5a55018647227e127e13d5c6a790 /dev-python/pbr
parentmate-base/mate-applets revert backport kernel 4.7 support (diff)
downloadgentoo-083f371f720dcfbddc292f5f172e31d62c66552a.tar.gz
gentoo-083f371f720dcfbddc292f5f172e31d62c66552a.tar.bz2
gentoo-083f371f720dcfbddc292f5f172e31d62c66552a.zip
doing the test
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/pbr-1.8.1-r1.ebuild72
1 files changed, 0 insertions, 72 deletions
diff --git a/dev-python/pbr/pbr-1.8.1-r1.ebuild b/dev-python/pbr/pbr-1.8.1-r1.ebuild
deleted file mode 100644
index db2b0efbf085..000000000000
--- a/dev-python/pbr/pbr-1.8.1-r1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
-HOMEPAGE="https://github.com/openstack-dev/pbr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/fixtures-1.3.1[${PYTHON_USEDEP}]
- >=dev-python/mock-1.2[${PYTHON_USEDEP}]
- >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- !~dev-python/sphinx-1.2.0[${PYTHON_USEDEP}]
- <dev-python/sphinx-1.3[${PYTHON_USEDEP}]
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
- >=dev-python/testresources-0.2.4[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-1.4.0[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- dev-vcs/git
- )"
-PDEPEND=""
-
-# This normally actually belongs here.
-python_prepare_all() {
- # This test passes when run within the source and doesn't represent a failure, but rather
- # a gentoo sandbox constraint
- # Rm tests that rely upon the package being already installed and fail
- sed -e s':test_console_script_develop:_&:' \
- -e s':test_console_script_install:_&:' \
- -e s':test_sdist_extra_files:_&:' \
- -e s':test_command_hooks:_&:' \
- -e s':test_sdist_git_extra_files:_&:' \
- -i pbr/tests/test_core.py || die
- sed -e s':test_command_hooks:_&:' \
- -e s':test_global_setup_hooks:_&:' \
- -i pbr/tests/test_hooks.py || die
- sed \
- -e "s:test_wsgi_script_install:_&:" \
- -i pbr/tests/test_wsgi.py || die
- einfo "rogue tests disabled"
- sed -i '/^hacking/d' test-requirements.txt || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- distutils_install_for_testing
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}