summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-31 15:57:45 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-31 16:17:54 +0200
commit4780a5941eb2c5779898237f66b7c35e56f094ae (patch)
tree9bc17f4dc403ee3a07adb5dba8c0456657819b44 /dev-python/pbr
parentdev-embedded/freaklabs-boards: avoid space in distfile name (diff)
downloadgentoo-4780a5941eb2c5779898237f66b7c35e56f094ae.tar.gz
gentoo-4780a5941eb2c5779898237f66b7c35e56f094ae.tar.bz2
gentoo-4780a5941eb2c5779898237f66b7c35e56f094ae.zip
dev-python/pbr: Bump to 5.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-5.4.5.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 585bf23c8a1d..72e332c1fc6c 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -2,4 +2,5 @@ DIST pbr-3.1.1.tar.gz 102665 BLAKE2B 301515d50f8550f5553a29faacb1daef589b41b8116
DIST pbr-4.1.1.tar.gz 108683 BLAKE2B 5c0157ff14590113e7baae0bdca1ff46108a7a10d6eae8bd0a2d06bee62b4aa65eed25c900ae1b67324ac6b416641081c63a274c9694db1877b5d9073c1c04d9 SHA512 ed739901b3a2d1eafa1d4d408a39f1e5d967776571efe0913877145aaccee3114558e107a4e5704403288324c63a08cfbca07a3409bd1baafcbc33105abdf3e4
DIST pbr-4.2.0.tar.gz 107958 BLAKE2B 716283ceb7b1a8da41e77441c7526bf8cbdb5be7c710013630d3bbddf7de0ce37f3abd063f6103f3ec27fc5c09796f6452d8117df3b533b3c7377bf6dce7d37f SHA512 d46d93333b4d0d3fd5c14e0a474ca7beceddf794a5dbcf66f810993b8d33b48602518072effcd429566f4eede2a38c4aec289df262c2c0e7ab4b82474e14f14d
DIST pbr-5.1.1.tar.gz 113476 BLAKE2B 9e4857f13eba2e18abffa3d7c56f05eb5a5997b855f02770a807cec110e6eb4596b333b67beba2a507bb8cb55fcd3ed87a012b4a3a245b81d0a74737c010f157 SHA512 cd6f8bdc6db80841e948dbb278423556861aa681b970050a40c920dd00e32704a29cfdd28aabd4d14e0e577fff1bc816f0646a62c9450d0d85233ab5802606f1
+DIST pbr-5.4.5.tar.gz 120510 BLAKE2B f0f22a25e41820a0848aface6c241e38d8c4500d14ac3c8abf3d3b5f3f2d88680505d43f045589d700e9c07ade1643712274b156832246ca3f2050f44e4cda26 SHA512 b53ca10b7af7e365ff99ecf11942d3f047112d69f7e963716d07bc156077b08d79bb708bb93aae342e5e03c83278507b6990137dc34d0ebc11de53bd57ab3654
DIST pbr-wheel.patch 2781 BLAKE2B f36ac5bfe22e97dd93735581461f5ac79753543e0e03bcf569d95a3bfac70362c50af8bfc745e5d29ff07092e9669782ddaf3f8edd70501966c4d4682a5bfa33 SHA512 3c89eb9ea617da1d3e2eca3fadff6f5be9f55e4a258e1fbcdd221f3c0ec3cbfd13abe401bdfdb4b464baf74b8111e981f2dab4fb2839a4b52aee65212d1589f5
diff --git a/dev-python/pbr/pbr-5.4.5.ebuild b/dev-python/pbr/pbr-5.4.5.ebuild
new file mode 100644
index 000000000000..df8874245401
--- /dev/null
+++ b/dev-python/pbr/pbr-5.4.5.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
+HOMEPAGE="https://github.com/openstack-dev/pbr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~x86 ~amd64-linux ~x86-linux"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
+# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
+# stestr is run as external tool
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ $(python_gen_cond_dep '
+ >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/virtualenv-20[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.1.0
+ dev-vcs/git
+ ' -3)
+ )"
+PDEPEND=""
+
+# This normally actually belongs here.
+python_prepare_all() {
+ # TODO: investigate
+ sed -e s':test_console_script_develop:_&:' \
+ -e s':test_console_script_install:_&:' \
+ -i pbr/tests/test_core.py || die
+ # broken on pypy3
+ # https://bugs.launchpad.net/pbr/+bug/1881479
+ sed -e 's:test_generates_c_extensions:_&:' \
+ -i pbr/tests/test_packaging.py || die
+ rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ if ! python_is_python3; then
+ ewarn "Skipping tests on ${EPYTHON} to unblock circular deps."
+ ewarn "Please run tests manually."
+ return
+ fi
+
+ distutils_install_for_testing
+ local -x PATH=${TEST_DIR}/scripts:${PATH}
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ stestr init || die "stestr init failed under ${EPYTHON}"
+ stestr run || die "stestr run failed under ${EPYTHON}"
+}