summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-21 22:13:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-21 22:13:16 +0200
commitf571ddc6ca347f7016b4446b4ead59b3de616578 (patch)
tree5987c0ac8acb70abbc4c444d58741637d406de7a /dev-python/pbr
parentdev-python/requests-toolbelt: Remove old (diff)
downloadgentoo-f571ddc6ca347f7016b4446b4ead59b3de616578.tar.gz
gentoo-f571ddc6ca347f7016b4446b4ead59b3de616578.tar.bz2
gentoo-f571ddc6ca347f7016b4446b4ead59b3de616578.zip
dev-python/pbr: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pbr')
-rw-r--r--dev-python/pbr/Manifest1
-rw-r--r--dev-python/pbr/pbr-5.8.0-r1.ebuild69
2 files changed, 0 insertions, 70 deletions
diff --git a/dev-python/pbr/Manifest b/dev-python/pbr/Manifest
index 1a898093aece..61894ff9cbb6 100644
--- a/dev-python/pbr/Manifest
+++ b/dev-python/pbr/Manifest
@@ -1,2 +1 @@
-DIST pbr-5.8.0.tar.gz 127170 BLAKE2B 7fbd166f01617617c0dff568d1bb88a4be03d62f4f0c3ca1a7d16a7cefb20dcc924ffbb8df0d2d34516cfe3b60b8e380a0eb4a1071220bb4ab695d3d7c88d824 SHA512 61a8eb63bb76ce8515c4203d60df7c973e02ea61b603d155b611724efb2b15c42416bf8a0285451d3378056d390bbf63d991cec32cc4114ae5cc30ebae0a5a69
DIST pbr-5.9.0.tar.gz 126893 BLAKE2B 3f1d39c037afa7fe6d45b0b039968243e99717b347d1f1ada25023a64e7e683c0d83d2ce177e0f7c5f4cb65cd2a0eedd594b463d5d72bdc86560d811bd3f0cd3 SHA512 b36cc331664b91899a884bb1bc6980174ba2463db35c591d480d0b5a49dd37781132893e488c6a9238fbd2ec16589652d66b01a8c2701d02ff5c0b04e9c6121b
diff --git a/dev-python/pbr/pbr-5.8.0-r1.ebuild b/dev-python/pbr/pbr-5.8.0-r1.ebuild
deleted file mode 100644
index 0c4254d5cca3..000000000000
--- a/dev-python/pbr/pbr-5.8.0-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-PYTHON_REQ_USE="threads(+)"
-inherit distutils-r1
-
-DESCRIPTION="Inject some useful and sensible default behaviors into setuptools"
-HOMEPAGE="https://github.com/openstack/pbr/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/setuptools-60.5.0[${PYTHON_USEDEP}]
-"
-# git is needed for tests, see https://bugs.launchpad.net/pbr/+bug/1326682 and https://bugs.gentoo.org/show_bug.cgi?id=561038
-# docutils is needed for sphinx exceptions... https://bugs.gentoo.org/show_bug.cgi?id=603848
-# stestr is run as external tool
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- >=dev-python/wheel-0.32.0[${PYTHON_USEDEP}]
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/six-1.12.0[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/testresources-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
- >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.0.3[${PYTHON_USEDEP}]
- dev-vcs/git
- ' 'python*')
- )"
-
-distutils_enable_tests unittest
-
-# This normally actually belongs here.
-python_prepare_all() {
- # TODO: investigate
- sed -e s':test_console_script_develop:_&:' \
- -e s':test_console_script_install:_&:' \
- -i pbr/tests/test_core.py || die
- # broken on pypy3
- # https://bugs.launchpad.net/pbr/+bug/1881479
- sed -e 's:test_generates_c_extensions:_&:' \
- -i pbr/tests/test_packaging.py || die
- rm pbr/tests/test_wsgi.py || die "couldn't remove wsgi network tests"
- # installs random packages via pip from the Internet
- sed -e 's:test_requirement_parsing:_&:' \
- -e 's:test_pep_517_support:_&:' \
- -i pbr/tests/test_packaging.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- if [[ ${EPYTHON} != python* ]]; then
- einfo "Testing on ${EPYTHON} is not supported at the moment"
- return
- fi
-
- distutils_install_for_testing
- eunittest -b
-}