summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-30 13:50:19 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-30 14:46:21 -0500
commitd8a692822bedc360d53d7fb00ea116dcdfd3a17a (patch)
tree99f4d2858feb0c0a28da19fecdcfcc0b2960ad5f /dev-python/pecan
parentmedia-sound/clementine: Replaced fdo-mime with xdg-utils eclass. (diff)
downloadgentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.tar.gz
gentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.tar.bz2
gentoo-d8a692822bedc360d53d7fb00ea116dcdfd3a17a.zip
dev-python/pecan: 1.2.1 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/pecan')
-rw-r--r--dev-python/pecan/Manifest1
-rw-r--r--dev-python/pecan/pecan-1.2.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pecan/Manifest b/dev-python/pecan/Manifest
index 7a0bbbadda7e..c994c3f5c7cd 100644
--- a/dev-python/pecan/Manifest
+++ b/dev-python/pecan/Manifest
@@ -1,2 +1,3 @@
DIST pecan-1.0.4.tar.gz 119575 SHA256 0ecaa56bd3e1643af671dda9c293992b0e086c52cd7d19ab37bd56169a6effa8 SHA512 cbd5bc21658e68553baa55b74f82f7198ba261bf48d2889732ebbdbcb7f00d0a68f85dcaf946e7349000e78217c532d2017606316335211abd1fac15b947ed7f WHIRLPOOL d13c61ea5fced23a745c05f006218e5851418563fb5199fbdf20652edd0aea4d552407ef7ff9d8b4bb32f53c5bfc7d3767e79ba02bb206910a89aa8a90f9c1df
DIST pecan-1.1.2.tar.gz 120316 SHA256 e7969d9068d0185997f4affca86755771e5db2edf7aa6238be2bebfb4dd6e662 SHA512 672771fb8645bd11f6d89e7be46b6a85ea640b1951cc286cfedc7813f4f076e8435474adcf88d5c149b4d3933fea9c458b155df8b0ce491dac54bad46e4186be WHIRLPOOL c25ce7af4ccc7e3873453e3829ec6b7c3e6dda0fcef9c20efa14e857b54fbde1a65495f5ad27d2b5a00bff95062bf8da78923a19e1042622acc9c7adbe28cbf1
+DIST pecan-1.2.1.tar.gz 120364 SHA256 8d95457b9cedcfda9b467f5cc7dde8cdf72ddba6b402d6a5902843d1b2186c46 SHA512 ce7007f2ea9cf01b7375919c1624b8bf9b8a836d383b6a1906b6d33190b6586ae8700149d862a6a9f16d7eb5e29d055540a13122f67bd3074270e3791a82a233 WHIRLPOOL b220f670f3d498dbc15faaeda3093a422a5469118b223e35295d4ac7413a305d10705c93eeb8a993cb89459029c8f449fd17ee8c34a6f4cb259e37f1c3aa0a10
diff --git a/dev-python/pecan/pecan-1.2.1.ebuild b/dev-python/pecan/pecan-1.2.1.ebuild
new file mode 100644
index 000000000000..3021c4cc8f28
--- /dev/null
+++ b/dev-python/pecan/pecan-1.2.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="A WSGI object-dispatching web framework, lean, fast, with few dependencies."
+HOMEPAGE="https://pypi.python.org/pypi/pecan"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/simplejson-2.1.1[${PYTHON_USEDEP}]
+ virtual/python-singledispatch[${PYTHON_USEDEP}]
+ dev-python/ordereddict[$(python_gen_usedep 'python2_7')]
+ >=dev-python/webob-1.4[${PYTHON_USEDEP}]
+ >=dev-python/mako-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/webtest-1.3.1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/logutils-0.3.0[${PYTHON_USEDEP}]"