summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2020-04-25 19:52:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-04-26 18:53:09 +0200
commitfb3b75d775473324156569085acdd5efe77fe079 (patch)
tree58fa34ba8a27ca422b1324a4b818eb4f3dbb8f98 /dev-python/peewee/peewee-3.13.2.ebuild
parentdev-perl/AnyEvent-CacheDNS: Add licensing note for potential future use (diff)
downloadgentoo-fb3b75d775473324156569085acdd5efe77fe079.tar.gz
gentoo-fb3b75d775473324156569085acdd5efe77fe079.tar.bz2
gentoo-fb3b75d775473324156569085acdd5efe77fe079.zip
dev-python/peewee: Bump to 3.13.2, py3.{7,8}
Closes: https://bugs.gentoo.org/707370 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/15346 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/peewee/peewee-3.13.2.ebuild')
-rw-r--r--dev-python/peewee/peewee-3.13.2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/peewee/peewee-3.13.2.ebuild b/dev-python/peewee/peewee-3.13.2.ebuild
new file mode 100644
index 000000000000..36f6047511b1
--- /dev/null
+++ b/dev-python/peewee/peewee-3.13.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Small Python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( dev-python/psycopg[${PYTHON_USEDEP}] )"
+DEPEND="dev-python/cython[${PYTHON_USEDEP}]"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ "${EPYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && DOCS=( examples/ )
+ distutils-r1_python_install_all
+}