summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-27 10:10:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-27 10:21:18 +0100
commit0047558ff257088fe3af19c63de08cc3c007e1d6 (patch)
treea0a2f95606af64a6bfc234cc7e5d86a4bdfa6dc6 /dev-python/pep517
parentdev-python/mediafile: Switch to PEP 517 build (diff)
downloadgentoo-0047558ff257088fe3af19c63de08cc3c007e1d6.tar.gz
gentoo-0047558ff257088fe3af19c63de08cc3c007e1d6.tar.bz2
gentoo-0047558ff257088fe3af19c63de08cc3c007e1d6.zip
dev-python/pep517: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pep517')
-rw-r--r--dev-python/pep517/pep517-0.12.0-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pep517/pep517-0.12.0-r1.ebuild b/dev-python/pep517/pep517-0.12.0-r1.ebuild
new file mode 100644
index 000000000000..a3a9f5cda36b
--- /dev/null
+++ b/dev-python/pep517/pep517-0.12.0-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Wrappers to build Python packages using PEP 517 hooks"
+HOMEPAGE="
+ https://pypi.org/project/pep517/
+ https://github.com/pypa/pep517/
+ https://pep517.readthedocs.io/"
+SRC_URI="
+ https://github.com/pypa/pep517/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ dev-python/tomli[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/testpath[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # require Internet
+ tests/test_meta.py
+)
+
+src_prepare() {
+ sed -i -e '/--flake8/d' pytest.ini || die
+ distutils-r1_src_prepare
+}