summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2016-06-12 08:12:32 +0200
committerJohann Schmitz <ercpe@gentoo.org>2016-06-12 08:12:32 +0200
commit687e78e4f8abca6bc9770a996b3ce5181b8b6102 (patch)
treef40fa98aa79a158592513366f24b37289f05fabe /dev-python/phonenumbers/phonenumbers-7.2.8.ebuild
parentdev-ruby/loquacious: add ruby23 (diff)
downloadgentoo-687e78e4f8abca6bc9770a996b3ce5181b8b6102.tar.gz
gentoo-687e78e4f8abca6bc9770a996b3ce5181b8b6102.tar.bz2
gentoo-687e78e4f8abca6bc9770a996b3ce5181b8b6102.zip
dev-python/phonenumbers: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/phonenumbers/phonenumbers-7.2.8.ebuild')
-rw-r--r--dev-python/phonenumbers/phonenumbers-7.2.8.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/phonenumbers/phonenumbers-7.2.8.ebuild b/dev-python/phonenumbers/phonenumbers-7.2.8.ebuild
new file mode 100644
index 000000000000..e56e0fad2e7f
--- /dev/null
+++ b/dev-python/phonenumbers/phonenumbers-7.2.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python port of Google's libphonenumber"
+HOMEPAGE="https://github.com/daviddrysdale/python-phonenumbers"
+SRC_URI="https://github.com/daviddrysdale/python-${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/python-${PN}-release-${PV}"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test
+} \ No newline at end of file