summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-06-14 16:01:37 +0200
committerSebastian Pipping <sping@gentoo.org>2017-06-14 16:26:04 +0200
commit9f51dca4b57da4de84548e762d4fe0bb36d28d87 (patch)
tree19aa6c2720d12f9f329c17afc6cae3a2191b31af /dev-python/piexif/piexif-1.0.12.ebuild
parentapp-emulation/spice-vdagent: improve kernel config warning (diff)
downloadgentoo-9f51dca4b57da4de84548e762d4fe0bb36d28d87.tar.gz
gentoo-9f51dca4b57da4de84548e762d4fe0bb36d28d87.tar.bz2
gentoo-9f51dca4b57da4de84548e762d4fe0bb36d28d87.zip
dev-python/piexif: New package
For upcoming =www-apps/nikola-7.8.8 (bug #565846) Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/piexif/piexif-1.0.12.ebuild')
-rw-r--r--dev-python/piexif/piexif-1.0.12.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/piexif/piexif-1.0.12.ebuild b/dev-python/piexif/piexif-1.0.12.ebuild
new file mode 100644
index 000000000000..1f3c4871b820
--- /dev/null
+++ b/dev-python/piexif/piexif-1.0.12.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Exif manipulation with pure Python"
+HOMEPAGE="https://github.com/hMatoba/Piexif
+ https://pypi.python.org/pypi/piexif"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ app-arch/unzip
+ test? ( dev-python/pillow )"
+
+python_test() {
+ "${PYTHON}" setup.py test
+}