summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-01-12 23:25:50 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-01-12 23:26:36 +0700
commit0b44c5508c28bc0406d543f89cadbac346426f99 (patch)
tree997be01408f5a4ed50129316ec943aea5214fdc9 /dev-python/pikepdf
parentapp-emulation/docker-compose: 1.28.0_rc3 (diff)
downloadgentoo-0b44c5508c28bc0406d543f89cadbac346426f99.tar.gz
gentoo-0b44c5508c28bc0406d543f89cadbac346426f99.tar.bz2
gentoo-0b44c5508c28bc0406d543f89cadbac346426f99.zip
dev-python/pikepdf: bump to 2.3.0
Closes: https://bugs.gentoo.org/764806 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-python/pikepdf')
-rw-r--r--dev-python/pikepdf/Manifest1
-rw-r--r--dev-python/pikepdf/pikepdf-2.3.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/pikepdf/Manifest b/dev-python/pikepdf/Manifest
index 9f84637789b4..2e7ac00a789f 100644
--- a/dev-python/pikepdf/Manifest
+++ b/dev-python/pikepdf/Manifest
@@ -1,2 +1,3 @@
DIST pikepdf-1.18.0.tar.gz 2351789 BLAKE2B b33b69f57fcd5293814ac880376627b7184ca632e09f668fd274eae6b3640d97699681597470c17abe00ec334ec894a073cc1a1eff91ffa7df572ef78542b429 SHA512 9a04fe6ce145a6f28a180261ac004fc0ce3c525c4e9e7c5eb4bb7dbf8aaa6d3e6f726cec5d20033a5aaa60b793666df52c20f13c8ee7c0c3266fb8e557d69c18
DIST pikepdf-2.2.0.tar.gz 2363761 BLAKE2B d1a8873a2c41e280dc2880609424742f4454ee226ee30469df067ddf0f5ee98ba6ef2965df75e95c2576e3813bdea7cb6bebfc7a1a7d05696b9da8ec67ef981a SHA512 e80874ece09ce6381079f705ab031b121917485d0968578aeb07a83b70a14bb46d549498357acc4df62b51c33fd75a87f65b74ef64464dcaebba3ff84aaa1843
+DIST pikepdf-2.3.0.tar.gz 2366792 BLAKE2B 3e5d2f460702bbce8ddc22abfb67867b40f75bb59cd30966db9865c96240ef9ad990f295abcd8f5f325a9954500e587afab647da7de3909960859fa3825c4526 SHA512 056bd2e73a7915b42ea170061932e445fff614abd662d935c8735c5fb04fd95e196495bc11dcb3781270c966d94cb93cd972500e6ea4d3ea7333456be3b7dbb6
diff --git a/dev-python/pikepdf/pikepdf-2.3.0.ebuild b/dev-python/pikepdf/pikepdf-2.3.0.ebuild
new file mode 100644
index 000000000000..e1542ac56bba
--- /dev/null
+++ b/dev-python/pikepdf/pikepdf-2.3.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Python library to work with pdf files based on qpdf"
+HOMEPAGE="https://pypi.org/project/pikepdf/ https://github.com/pikepdf/pikepdf"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="app-text/qpdf:0=
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/pybind11[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-50[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.35[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-4.1[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ dev-python/setuptools_scm_git_archive[${PYTHON_USEDEP}]
+ test? ( >=dev-python/attrs-20.2.0[${PYTHON_USEDEP}]
+ >=dev-python/hypothesis-5[${PYTHON_USEDEP}]
+ <dev-python/hypothesis-6.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-6[${PYTHON_USEDEP}]
+ <dev-python/pytest-7[${PYTHON_USEDEP}]
+ >=dev-python/pytest-cov-2.10.1[${PYTHON_USEDEP}]
+ <dev-python/pytest-cov-3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.28[${PYTHON_USEDEP}]
+ <dev-python/pytest-xdist-2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-1.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-dateutil-2.8.0[${PYTHON_USEDEP}]
+ >=dev-python/python-xmp-toolkit-2.0.1[${PYTHON_USEDEP}] )"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.8.3-test.patch )
+
+python_test() {
+ pytest
+}
+
+# When ipython and matplotlib will get python3_8 support, we'll be able to add
+#
+#IUSE="doc"
+#DEPEND="doc? ( dev-python/ipython
+# dev-python/matplotlib
+# dev-python/sphinx-1.4
+# dev-python/sphinx_rtd_theme )"
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+#python_install_all() {
+# use doc && local HTML_DOCS=( docs/_build/html/. )
+# distutils-r1_python_install_all
+#}