summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-02 09:14:32 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-02 09:14:32 +0100
commit5b303534d1a68fd96d2c34d291ef003af26fb724 (patch)
treee9d1c5a92dcd3fa78ab7c60778af96a2ac5838ab /dev-python/pillow
parentdev-python/argon2_cffi: Update HOMEPAGE (diff)
downloadgentoo-5b303534d1a68fd96d2c34d291ef003af26fb724.tar.gz
gentoo-5b303534d1a68fd96d2c34d291ef003af26fb724.tar.bz2
gentoo-5b303534d1a68fd96d2c34d291ef003af26fb724.zip
dev-python/pillow: Bump to 7.0.0 (py3 only)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pillow')
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-7.0.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index d890e174f2f6..6fde61b6d7ff 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -2,3 +2,4 @@ DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14d
DIST pillow-5.4.1.tar.gz 15799745 BLAKE2B d9e3851a80a1f94d7292852b9ab806d9a26870795f499bb109a440e64c07112055a4cd382688b977f3c3ae76ed3d6fd38460afff594f964338afa668d288e4de SHA512 20b75ab50df7e9545c76d66ad585922d1f86fbcf8df9d2566882ab8929c3122573b9ec622766523ec46f5e7a98740cc78ff192e3e8f08ab0b77a7f2b033a7f62
DIST pillow-6.2.1.tar.gz 37405020 BLAKE2B bf3592bcc159902acc35899463c8949daf7cc31f03283684dc55d5f1517fdfbc07e1feb73b65b0b9cb4052ee1d5281558b38f9bd08240d0fc5727909b98da158 SHA512 ee757ec2b8382d6d56fd0f0cdd4cd36440cc37f05741e27fc661449a16dc7c868966772060adb283de1b1b5ebc49b8eec46e0bdcdad9f5f4d5ebd77feab7ad31
DIST pillow-6.2.2.tar.gz 37538464 BLAKE2B dfd9b81490a8adb4e12ecbf6764e4e27573c9a087877ac37275a9fb42b89f0cd8cab8d7ca0b45c9a00bf38ca5b1d83de68f5fc35ff19031bfcc1495ee3a5f5b7 SHA512 0f2c3bfd921247fa11645eadc42e184182a401ccbdb8f10215312e96c8c28f2382f5413b56acd78fab1dffc6fa53cc8588ce960543af65c4769451874c2c918e
+DIST pillow-7.0.0.tar.gz 37880130 BLAKE2B be940cbdced884c33f2b3979be113b1bc8974814c9532fe80203395184f90eccba1cd9a5017fec1f0c30a21ff06abc46560d5c6d67938dbf640f2e8e08b7e554 SHA512 187173a525d4f3f01b4898633263b53a311f337aa7b159c64f79ba8c7006fd44798a058e7cc5d8f1116bad008e4142ff303456692329fe73b0e115ef5c225d73
diff --git a/dev-python/pillow/pillow-7.0.0.ebuild b/dev-python/pillow/pillow-7.0.0.ebuild
new file mode 100644
index 000000000000..04853bc300ad
--- /dev/null
+++ b/dev-python/pillow/pillow-7.0.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
+REQUIRED_USE="test? ( jpeg tiff )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/olefile[${PYTHON_USEDEP}]
+ imagequant? ( media-gfx/libimagequant:0 )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ zlib? ( sys-libs/zlib:0= )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[png]
+ )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
+ --disable-platform-guessing
+ $(use_enable truetype freetype)
+ $(use_enable jpeg)
+ $(use_enable jpeg2k jpeg2000)
+ $(use_enable lcms)
+ $(use_enable tiff)
+ $(use_enable imagequant)
+ $(use_enable webp)
+ $(use_enable webp webpmux)
+ $(use_enable zlib)
+ )
+
+ # setup.py sucks at adding the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but this setup.py does stupid things.
+ export \
+ INCLUDE=${ESYSROOT}/usr/include \
+ LIB=${ESYSROOT}/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}