summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-08-27 09:58:56 +0200
committerJustin Lecher <jlec@gentoo.org>2015-08-27 09:58:56 +0200
commitbf410198759837aed7fa5099e64d63a89dc71dec (patch)
treec21d56fca8980ad84334f84f5838bde4d96ef77d /dev-python/pip/pip-7.1.2.ebuild
parentnet-wireless/spectools: Add fix for ncurses[tinfo] (diff)
downloadgentoo-bf410198759837aed7fa5099e64d63a89dc71dec.tar.gz
gentoo-bf410198759837aed7fa5099e64d63a89dc71dec.tar.bz2
gentoo-bf410198759837aed7fa5099e64d63a89dc71dec.zip
dev-python/pip: Resolve circular deps,
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=558808 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/pip/pip-7.1.2.ebuild')
-rw-r--r--dev-python/pip/pip-7.1.2.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-python/pip/pip-7.1.2.ebuild b/dev-python/pip/pip-7.1.2.ebuild
index 1a0c9d3b032f..2c47eb85bba8 100644
--- a/dev-python/pip/pip-7.1.2.ebuild
+++ b/dev-python/pip/pip-7.1.2.ebuild
@@ -30,10 +30,12 @@ VENDOR_DEPEND="
>=dev-python/packaging-15.3[${PYTHON_USEDEP}]
>=dev-python/retrying-1.3.3[${PYTHON_USEDEP}]
"
-RDEPEND="${VENDOR_DEPEND}
+RDEPEND="
>=dev-python/setuptools-18.2[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+# circular #558808
+PDEPEND="${VENDOR_DEPEND}"
# required test data isn't bundled with the tarball
RESTRICT="test"