summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-09 20:19:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-09 22:17:12 +0200
commitc9ec7571f9abe6d942eec8c3899e7c099cb9b74f (patch)
tree8dddf100a9a06ed3b8dd9a7e2c43c5246d158388 /dev-python/pip
parentdev-python/protobuf-python: Version bump (3.17.3). (diff)
downloadgentoo-c9ec7571f9abe6d942eec8c3899e7c099cb9b74f.tar.gz
gentoo-c9ec7571f9abe6d942eec8c3899e7c099cb9b74f.tar.bz2
gentoo-c9ec7571f9abe6d942eec8c3899e7c099cb9b74f.zip
dev-python/pip: Use local virtualenv-16 for testing
Fetch and use a local copy of virtualenv-16 instead of using the system package. This removes the for upgrade to virtualenv-20, and it should make maintenance much less painful. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pip')
-rw-r--r--dev-python/pip/Manifest1
-rw-r--r--dev-python/pip/files/virtualenv-16.7.10-py310.patch84
-rw-r--r--dev-python/pip/pip-21.1.2-r1.ebuild133
3 files changed, 218 insertions, 0 deletions
diff --git a/dev-python/pip/Manifest b/dev-python/pip/Manifest
index d25199fe58cf..e47711af1e9d 100644
--- a/dev-python/pip/Manifest
+++ b/dev-python/pip/Manifest
@@ -1,4 +1,5 @@
DIST pip-21.1.1.tar.gz 8771867 BLAKE2B 1cb920ab52510e816a7c3b8b6d1b47576a27cf1b208ab8fefa102ff36c09eb4e99b34f213a043550a9e6fb37bb8b6306f9e939371661ff7f23ba03f21b4a643b SHA512 05157ed586597f16948afdad43d98cc095803d2d22b1427ac1028ca2a73a26d65e597446808194343ed36f9eb7cb910ac89e73a6a9a90ee868ec822fdbe641c5
DIST pip-21.1.2.tar.gz 8772481 BLAKE2B 23dbcc5dd7e7f66934282b9c93958267eb367d418b6c814032b7b89e0d94c73c143626781b8df081394019d2e575030b7a2fd61bb5221992ce2060cf069e8b04 SHA512 54a2b6074fcb2640868dedcabb5087b79a53a8ad57ec4ab5acf2862b8037403d8f156c2853ab60c2f10c6af999a0a90774f0bc3eca2978a82590935d37af167f
DIST setuptools-56.0.0-py3-none-any.whl 784941 BLAKE2B 136352bcaeeb803f94983db2e0f9ec79dacc23a6742a2f6f1b4bdd2b29a104f4965d78f9b4adf1a501c7bf39d4ed85a6786b03489f90872661afbf5e674fd3f9 SHA512 32405236e9c2936cde137bc4d4d07b548391336ce0511cd5677dcd1f85c7a142b0947e03cdceaeb37067874f5aa71daacaa1a6af95ae9fe3ad8af264f61e10f4
+DIST virtualenv-16.7.10.tar.gz 5116776 BLAKE2B 42f0a4b4330850b504f8febd991ef6ecdcbb0821efdd94ca324a8cc34a68a760a8a98de97f0cb2384d8e6cbb0ce8f261995c6433886444e29b75ba0ce09ca12c SHA512 f06d7c354ce1910f04dbcbe1a77e60392653bbe4f638bafbe9284454db2c0e5d63cf9159201d0916fc01aaba91d45fb733b63096c38517fcd83fd00ed8b26d28
DIST wheel-0.36.2-py2.py3-none-any.whl 35046 BLAKE2B bc4e8dab7c74eea34d3b4a813b7eaf6295a99a396a861b6cdd76f743043e89140bad132bdd13e385e8945ce02e0798e1d3ac73fc1b23bde5b2a83e4bb4dd5cdc SHA512 6bb5119b4d3704fe1e3c1eaaa3124edab13f61b46f8a0a8e75974fac4e5b25d8b53606071a03a8d8990ad1cfe2ab247ddea260098df2c0c35ae965be47080284
diff --git a/dev-python/pip/files/virtualenv-16.7.10-py310.patch b/dev-python/pip/files/virtualenv-16.7.10-py310.patch
new file mode 100644
index 000000000000..27c17a07445f
--- /dev/null
+++ b/dev-python/pip/files/virtualenv-16.7.10-py310.patch
@@ -0,0 +1,84 @@
+From b4aef0a53ba63c34e45413754705af4e438ef5df Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Wed, 5 May 2021 10:59:02 +0200
+Subject: [PATCH] Legacy: Use sysconfig.get_default_scheme() where available
+ (#2109)
+
+---
+ .pre-commit-config.yaml | 43 ------------------------------------
+ docs/changelog/2109.misc.rst | 1 +
+ virtualenv.py | 3 ++-
+ 3 files changed, 3 insertions(+), 44 deletions(-)
+ delete mode 100644 .pre-commit-config.yaml
+ create mode 100644 docs/changelog/2109.misc.rst
+
+diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
+deleted file mode 100644
+index 0b8234b7d..000000000
+--- a/.pre-commit-config.yaml
++++ /dev/null
+@@ -1,43 +0,0 @@
+-repos:
+-- repo: https://github.com/ambv/black
+- rev: 19.10b0
+- hooks:
+- - id: black
+- args: [--safe]
+- language_version: python3.8
+-- repo: https://github.com/asottile/blacken-docs
+- rev: v1.3.0
+- hooks:
+- - id: blacken-docs
+- additional_dependencies: [black==19.3b0]
+- language_version: python3.8
+-- repo: https://github.com/asottile/seed-isort-config
+- rev: v1.9.3
+- hooks:
+- - id: seed-isort-config
+- args: [--application-directories, '.']
+-- repo: https://github.com/pre-commit/mirrors-isort
+- rev: v4.3.21
+- hooks:
+- - id: isort
+-- repo: https://github.com/pre-commit/pre-commit-hooks
+- rev: v2.4.0
+- hooks:
+- - id: trailing-whitespace
+- - id: end-of-file-fixer
+- - id: check-yaml
+- - id: debug-statements
+- - id: check-merge-conflict
+- - id: trailing-whitespace
+- - id: check-docstring-first
+- - id: flake8
+- additional_dependencies: ["flake8-bugbear == 19.8.0"]
+- language_version: python3.8
+-- repo: https://github.com/asottile/pyupgrade
+- rev: v1.25.1
+- hooks:
+- - id: pyupgrade
+-- repo: https://github.com/pre-commit/pygrep-hooks
+- rev: v1.4.2
+- hooks:
+- - id: rst-backticks
+diff --git a/docs/changelog/2109.misc.rst b/docs/changelog/2109.misc.rst
+new file mode 100644
+index 000000000..985f955df
+--- /dev/null
++++ b/docs/changelog/2109.misc.rst
+@@ -0,0 +1 @@
++Preserve compatibility with Python 3.10 - by ``hroncok``
+diff --git a/virtualenv.py b/virtualenv.py
+index 3085d1d18..86aa65674 100755
+--- a/virtualenv.py
++++ b/virtualenv.py
+@@ -1809,7 +1809,8 @@ def fix_local_scheme(home_dir, symlink=True):
+ pass
+ else:
+ # noinspection PyProtectedMember
+- if sysconfig._get_default_scheme() == "posix_local":
++ get_scheme = getattr(sysconfig, "get_default_scheme", None) or sysconfig._get_default_scheme
++ if get_scheme() == "posix_local":
+ local_path = os.path.join(home_dir, "local")
+ if not os.path.exists(local_path):
+ os.mkdir(local_path)
diff --git a/dev-python/pip/pip-21.1.2-r1.ebuild b/dev-python/pip/pip-21.1.2-r1.ebuild
new file mode 100644
index 000000000000..69f4adb26c5c
--- /dev/null
+++ b/dev-python/pip/pip-21.1.2-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="ssl(+),threads(+)"
+
+inherit bash-completion-r1 distutils-r1
+
+# setuptools & wheel .whl files are required for testing,
+# the exact version is not very important.
+SETUPTOOLS_WHL="setuptools-56.0.0-py3-none-any.whl"
+WHEEL_WHL="wheel-0.36.2-py2.py3-none-any.whl"
+# upstream still requires virtualenv-16 for testing, we are now fetching
+# it directly to avoid blockers with virtualenv-20
+VENV_PV=16.7.10
+
+DESCRIPTION="Installs python packages -- replacement for easy_install"
+HOMEPAGE="
+ https://pip.pypa.io/en/stable/
+ https://pypi.org/project/pip/
+ https://github.com/pypa/pip/"
+SRC_URI="
+ https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ test? (
+ https://files.pythonhosted.org/packages/py3/s/setuptools/${SETUPTOOLS_WHL}
+ https://files.pythonhosted.org/packages/py2.py3/w/wheel/${WHEEL_WHL}
+ https://github.com/pypa/virtualenv/archive/${VENV_PV}.tar.gz
+ -> virtualenv-${VENV_PV}.tar.gz
+ )
+"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x64-macos"
+SLOT="0"
+IUSE="test vanilla"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/setuptools-39.2.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pretend[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/scripttest[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+ dev-python/wheel[${PYTHON_USEDEP}]
+ )
+"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-21.1-no-coverage.patch"
+ )
+ if ! use vanilla; then
+ PATCHES+=( "${FILESDIR}/pip-20.0.2-disable-system-install.patch" )
+ fi
+
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ mkdir tests/data/common_wheels/ || die
+ cp "${DISTDIR}"/{${SETUPTOOLS_WHL},${WHEEL_WHL}} \
+ tests/data/common_wheels/ || die
+
+ pushd "${WORKDIR}/virtualenv-${VENV_PV}" 2>/dev/null || die
+ eapply "${FILESDIR}/virtualenv-${VENV_PV}-py310.patch"
+ popd 2>/dev/null || die
+ fi
+}
+
+python_test() {
+ if [[ ${EPYTHON} == pypy* ]]; then
+ ewarn "Skipping tests on ${EPYTHON} since they are very broken"
+ return 0
+ fi
+
+ local deselect=(
+ tests/functional/test_install.py::test_double_install_fail
+ tests/functional/test_list.py::test_multiple_exclude_and_normalization
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-download]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-install]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-list]'
+ 'tests/unit/test_commands.py::test_index_group_handle_pip_version_check[False-False-True-wheel]'
+ tests/functional/test_install.py::test_install_pip_does_not_modify_pip_when_satisfied
+ # Internet
+ tests/functional/test_install.py::test_install_editable_with_prefix_setup_cfg
+ )
+
+ [[ ${EPYTHON} == python3.10 ]] && deselect+=(
+ tests/lib/test_lib.py::test_correct_pip_version
+ # uses vendored packaging that uses deprecated distutils
+ tests/functional/test_warning.py::test_pip_works_with_warnings_as_errors
+ )
+
+ distutils_install_for_testing
+ pushd "${WORKDIR}/virtualenv-${VENV_PV}" 2>/dev/null || die
+ distutils_install_for_testing
+ popd 2>/dev/null || die
+
+ local -x GENTOO_PIP_TESTING=1 \
+ PATH="${TEST_DIR}/scripts:${PATH}" \
+ PYTHONPATH="${TEST_DIR}/lib:${BUILD_DIR}/lib"
+ epytest ${deselect[@]/#/--deselect } -m "not network"
+}
+
+python_install_all() {
+ # Prevent dbus auto-launch
+ # https://bugs.gentoo.org/692178
+ export DBUS_SESSION_BUS_ADDRESS="disabled:"
+
+ local DOCS=( AUTHORS.txt docs/html/**/*.rst )
+ distutils-r1_python_install_all
+
+ COMPLETION="${T}"/completion.tmp
+
+ # 'pip completion' command embeds full $0 into completion script, which confuses
+ # 'complete' and causes QA warning when running as "${PYTHON} -m pip".
+ # This trick sets correct $0 while still calling just installed pip.
+ local pipcmd='import sys; sys.argv[0] = "pip"; from pip._internal.cli.main import main; sys.exit(main())'
+
+ ${PYTHON} -c "${pipcmd}" completion --bash > "${COMPLETION}" || die
+ newbashcomp "${COMPLETION}" ${PN}
+
+ ${PYTHON} -c "${pipcmd}" completion --zsh > "${COMPLETION}" || die
+ insinto /usr/share/zsh/site-functions
+ newins "${COMPLETION}" _pip
+}