summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2018-08-06 19:39:57 +0000
committerPatrick Lauer <patrick@gentoo.org>2018-08-06 19:40:11 +0000
commit6b3f223cb088e6ff683c80bfba690f2be5322844 (patch)
tree7d9d9a09732e5f0e300bc7af40f05bbb3ab6bbf0 /dev-python/pipenv
parentsys-process/audit: fix license (diff)
downloadgentoo-6b3f223cb088e6ff683c80bfba690f2be5322844.tar.gz
gentoo-6b3f223cb088e6ff683c80bfba690f2be5322844.tar.bz2
gentoo-6b3f223cb088e6ff683c80bfba690f2be5322844.zip
dev-python/pipenv: Add missing py2 dependencies
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/pipenv-9.0.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/pipenv/pipenv-9.0.0-r2.ebuild b/dev-python/pipenv/pipenv-9.0.0-r2.ebuild
new file mode 100644
index 000000000000..73a98b4733a8
--- /dev/null
+++ b/dev-python/pipenv/pipenv-9.0.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/flake8-3.0.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pew-0.1.26[${PYTHON_USEDEP}]
+ >=dev-python/pip-9.0.1[${PYTHON_USEDEP}]
+ >dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib[${PYTHON_USEDEP}]' 'python2_7')
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' 'python2_7')
+ "
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# not completely packed
+# requires networking
+RESTRICT="test"
+
+python_test() {
+ py.test -v -v || die
+}