summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2020-07-25 22:09:06 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-27 15:11:56 +0200
commitb0a47f581d627e7b48d29c67f308ae2b3757282b (patch)
treed52fed552a658e1a0d524f4abe1484096675641b /dev-python/pipenv
parentdev-python/pipenv: sign up oz.tiram@gmail.com for proxy-maint (diff)
downloadgentoo-b0a47f581d627e7b48d29c67f308ae2b3757282b.tar.gz
gentoo-b0a47f581d627e7b48d29c67f308ae2b3757282b.tar.bz2
gentoo-b0a47f581d627e7b48d29c67f308ae2b3757282b.zip
dev-python/pipenv: drop beta version 2020.4.1_beta1
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Oz Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16351 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 7cdbe4293463..85e36860fe58 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1,2 +1 @@
-DIST pipenv-2020.4.1_beta1.tar.gz 11331009 BLAKE2B 55ac81238b885bdf0293199ca1caf44a78f3cdbec75c9df259411b949dec8b385161e7ef46160ca099ef51041410d8c5d1274ad200eba5c2a9d06c8a5f61c5f1 SHA512 a5de90ae9910a30666ac7323ccf83b78ee11d8993aef1a2108a44f4256d365d0c1abfff72c83748ef82215914931090c670a10eeb511cb48483762b54c80e5c7
DIST pipenv-2020.6.2.tar.gz 11571734 BLAKE2B bc50535f215b11d284eeec546722a144cfdfeeab6abab8eae51c727c054865f274ac970dc61c23cce7db19ac28a77e44a84453743ba2dc75068feb3a47a19190 SHA512 671765b9e77a18039668eb500989de45c8bd4f15948ee914eb241985098562ebd382168a535a449ac5d216f07327b6787eb8f828b5a6499ef6e77fe5a036441e
diff --git a/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild b/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild
deleted file mode 100644
index 8182443641be..000000000000
--- a/dev-python/pipenv/pipenv-2020.4.1_beta1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-
-inherit distutils-r1
-
-MY_PV=${PV/_beta/b}
-DESCRIPTION="Python Development Workflow for Humans"
-HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
-SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/certifi[${PYTHON_USEDEP}]
- >=dev-python/pip-18.0[${PYTHON_USEDEP}]
- dev-python/virtualenv[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-clone-0.2.5[${PYTHON_USEDEP}]
- >=dev-python/setuptools-36.2.1[${PYTHON_USEDEP}]"
-DEPEND="test? (
- ${RDEPEND}
- dev-python/flaky[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- <dev-python/pytest-5[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- )"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}"/${PN}-${MY_PV}
-
-PATCHES=(
- "${FILESDIR}/${PN}-2020.4.1_beta1-disable-networked-tests.patch"
-)
-
-python_test() {
- pytest -m "not cli" -vv tests/unit || die
-}