summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOz N Tiram <oz.tiram@gmail.com>2021-11-11 13:52:31 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-11-22 16:03:37 +0200
commitd2f4c2dccccab721df906bd5443ae9dd060eba35 (patch)
tree0598e00cb56896c76387493167d459d5e97cbcc6 /dev-python/pipenv
parentapp-misc/physlock: Add patch to improve -h output (diff)
downloadgentoo-d2f4c2dccccab721df906bd5443ae9dd060eba35.tar.gz
gentoo-d2f4c2dccccab721df906bd5443ae9dd060eba35.tar.bz2
gentoo-d2f4c2dccccab721df906bd5443ae9dd060eba35.zip
dev-python/pipenv: add 2021.11.9
Signed-off-by: Oz N Tiram <oz.tiram@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22900 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/pipenv')
-rw-r--r--dev-python/pipenv/Manifest1
-rw-r--r--dev-python/pipenv/files/pipenv-2021-11-9-remove-attr-vendor-import.patch25
-rw-r--r--dev-python/pipenv/files/pipenv-2021-11-9-remove-colorama-vendor-import.patch67
-rw-r--r--dev-python/pipenv/pipenv-2021.11.9.ebuild65
4 files changed, 158 insertions, 0 deletions
diff --git a/dev-python/pipenv/Manifest b/dev-python/pipenv/Manifest
index 705aed4da95d..62ae2d9f3907 100644
--- a/dev-python/pipenv/Manifest
+++ b/dev-python/pipenv/Manifest
@@ -1 +1,2 @@
+DIST pipenv-2021.11.9.tar.gz 11652360 BLAKE2B ab7d733e0c44a8551d2b786680646f5efa9effdc6b6a74fc0b8286336c84b9795229036cc8b7179a4ee3d6c91701d82fdd2e8303c7c9a9da1e06eb78fb2a0214 SHA512 6ad44fe70d3e3f5bbdedb891c76ad1c37863e6f4215c34f2ef6aa1a35b89fb6262f8c55f7f2e71544e550d66d20567f12ce4698f9e3a899853aa49a0849c3189
DIST pipenv-2021.5.29.tar.gz 11607230 BLAKE2B 8eef8e79fbdfaf85a949437d06d9f8b48f7eaa6e4769f6d4ed90b01c0ebf70c282fc90581cce5ffcab0aeb6bc9ad770a8b4425f355a06e0fc4cd56fb221386e2 SHA512 4fa018c13d4babe856bf5671cf5d18a95f4af4b6d4fc64c4919825fe04004ed3d8979ca335b851c6e24dad081475f6fb5b925eeff58c6fb5cffc450b967ed1cd
diff --git a/dev-python/pipenv/files/pipenv-2021-11-9-remove-attr-vendor-import.patch b/dev-python/pipenv/files/pipenv-2021-11-9-remove-attr-vendor-import.patch
new file mode 100644
index 000000000000..2454d04f12ef
--- /dev/null
+++ b/dev-python/pipenv/files/pipenv-2021-11-9-remove-attr-vendor-import.patch
@@ -0,0 +1,25 @@
+From 0c31638a41a95ada109a3fd13e1e8380d2b8a731 Mon Sep 17 00:00:00 2001
+From: Oz N Tiram <oz.tiram@gmail.com>
+Date: Thu, 11 Nov 2021 13:05:13 +0100
+Subject: [PATCH 1/2] Remove vendored attr.
+
+---
+ pipenv/installers.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pipenv/installers.py b/pipenv/installers.py
+index 5baa1933..f7982ab6 100644
+--- a/pipenv/installers.py
++++ b/pipenv/installers.py
+@@ -3,7 +3,7 @@ import operator
+ import re
+ from abc import ABCMeta, abstractmethod
+
+-from pipenv.vendor import attr
++import attr
+ from pipenv.utils import find_windows_executable, subprocess_run
+
+
+--
+2.32.0
+
diff --git a/dev-python/pipenv/files/pipenv-2021-11-9-remove-colorama-vendor-import.patch b/dev-python/pipenv/files/pipenv-2021-11-9-remove-colorama-vendor-import.patch
new file mode 100644
index 000000000000..4677b0860da2
--- /dev/null
+++ b/dev-python/pipenv/files/pipenv-2021-11-9-remove-colorama-vendor-import.patch
@@ -0,0 +1,67 @@
+From 6e994dbc81c326b507c6f3119dfab56113dc17c3 Mon Sep 17 00:00:00 2001
+From: Oz N Tiram <oz.tiram@gmail.com>
+Date: Thu, 11 Nov 2021 13:05:41 +0100
+Subject: [PATCH 2/2] Remove vendored colorama
+
+---
+ pipenv/patched/crayons.py | 2 +-
+ pipenv/vendor/yaspin/core.py | 2 +-
+ tasks/vendoring/patches/patched/crayons.patch | 2 +-
+ tasks/vendoring/patches/vendor/yaspin-signal-handling.patch | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/pipenv/patched/crayons.py b/pipenv/patched/crayons.py
+index d7644a21..19b0d695 100644
+--- a/pipenv/patched/crayons.py
++++ b/pipenv/patched/crayons.py
+@@ -13,7 +13,7 @@ import re
+ import sys
+
+ from pipenv.vendor import shellingham
+-from pipenv.vendor import colorama
++import colorama
+
+ PY3 = sys.version_info[0] >= 3
+
+diff --git a/pipenv/vendor/yaspin/core.py b/pipenv/vendor/yaspin/core.py
+index d8a0716c..c9be016c 100644
+--- a/pipenv/vendor/yaspin/core.py
++++ b/pipenv/vendor/yaspin/core.py
+@@ -19,7 +19,7 @@ import time
+ from typing import List, Set, Union
+
+ from termcolor import colored
+-from pipenv.vendor import colorama
++import colorama
+ from pipenv.vendor.vistir import cursor
+
+ from .base_spinner import Spinner, default_spinner
+diff --git a/tasks/vendoring/patches/patched/crayons.patch b/tasks/vendoring/patches/patched/crayons.patch
+index 2760ca81..d021bfb1 100644
+--- a/tasks/vendoring/patches/patched/crayons.patch
++++ b/tasks/vendoring/patches/patched/crayons.patch
+@@ -10,7 +10,7 @@ index 455d3e90..de735daf 100644
+ -
+ -import colorama
+ +from pipenv.vendor import shellingham
+-+from pipenv.vendor import colorama
+++import colorama
+
+ +PY3 = sys.version_info[0] >= 3
+ +
+diff --git a/tasks/vendoring/patches/vendor/yaspin-signal-handling.patch b/tasks/vendoring/patches/vendor/yaspin-signal-handling.patch
+index 705650c3..95feb1c0 100644
+--- a/tasks/vendoring/patches/vendor/yaspin-signal-handling.patch
++++ b/tasks/vendoring/patches/vendor/yaspin-signal-handling.patch
+@@ -6,7 +6,7 @@ index 76dc2439..d8a0716c 100644
+ from typing import List, Set, Union
+
+ from termcolor import colored
+-+from pipenv.vendor import colorama
+++import colorama
+ +from pipenv.vendor.vistir import cursor
+
+ from .base_spinner import Spinner, default_spinner
+--
+2.32.0
+
diff --git a/dev-python/pipenv/pipenv-2021.11.9.ebuild b/dev-python/pipenv/pipenv-2021.11.9.ebuild
new file mode 100644
index 000000000000..7fa754b6731a
--- /dev/null
+++ b/dev-python/pipenv/pipenv-2021.11.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+DESCRIPTION="Python Development Workflow for Humans"
+HOMEPAGE="https://github.com/pypa/pipenv https://pypi.org/project/pipenv/"
+SRC_URI="https://github.com/pypa/pipenv/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-${PV//./-}-remove-attr-vendor-import.patch"
+ "${FILESDIR}/${PN}-${PV//./-}-remove-colorama-vendor-import.patch"
+ )
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+ >=dev-python/colorama-0.4.4[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0.1[${PYTHON_USEDEP}]
+ dev-python/pip[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.0.35[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.26.0[${PYTHON_USEDEP}]
+ >=dev-python/wheel-0.36.0[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ # remove vendored versions
+ # see https://bugs.gentoo.org/717666
+ rm -vR "${S}/${PN}/vendor/attr/" || die
+ rm -vR "${S}/${PN}/vendor/colorama/" || die
+ rm -vR "${S}/${PN}/vendor/requests/" || die
+ # not actually used by pipenv, but included in pipenv
+ rm -vR "${S}/${PN}/vendor/jinja2/" || die
+ rm -vR "${S}/${PN}/vendor/wheel/" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vvv -x -m "not cli and not needs_internet" tests/unit/ || die
+}