summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-28 12:52:34 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-28 12:59:28 +0100
commit745ee124804be414c729ab66695bc75c9f80ecd7 (patch)
tree1e9ef6e669ecbdc4d8be64e354b0295417122f48 /dev-python/pkginfo
parentdev-python/pkginfo: Stabilize 1.5.0.1 ALLARCHES (diff)
downloadgentoo-745ee124804be414c729ab66695bc75c9f80ecd7.tar.gz
gentoo-745ee124804be414c729ab66695bc75c9f80ecd7.tar.bz2
gentoo-745ee124804be414c729ab66695bc75c9f80ecd7.zip
dev-python/pkginfo: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pkginfo')
-rw-r--r--dev-python/pkginfo/Manifest2
-rw-r--r--dev-python/pkginfo/pkginfo-1.2.1.ebuild51
-rw-r--r--dev-python/pkginfo/pkginfo-1.4.2.ebuild47
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-python/pkginfo/Manifest b/dev-python/pkginfo/Manifest
index 7bd69642b034..26749b4bc951 100644
--- a/dev-python/pkginfo/Manifest
+++ b/dev-python/pkginfo/Manifest
@@ -1,3 +1 @@
-DIST pkginfo-1.2.1.tar.gz 31072 BLAKE2B 57ce5f6147b97af513dfdc6137180e5561822096cdbd21b673c49522384622c58f9eba8c65f24b54bc1e76dc0c6feede5d43e8aac945d94ffe79ea220e830470 SHA512 8a530a164befdcbc6f1f550e106880e14e9d2c762a5e1055f926ccf0228d9e2312f11598454ef015e97dccb78ac7aeb7309f34279590cd318c19c2bd9a29ed2a
-DIST pkginfo-1.4.2.tar.gz 33539 BLAKE2B d3cfc6bf7a9e748902b1f63434c745d8abf4e144c0a2b5d7a90236bfc2ce7f94922b0e08e5a08b13ba2025159bd90fecee25d9abdb283e7d52de0d34386aba59 SHA512 536628a2a2472e999695a115449a76f971453aea7ac3a08f10d9b08dfdf4a7b8e67c6010c6f18d300472a6afc8dff33331c955cc2f7bdb357504cd6a36390da3
DIST pkginfo-1.5.0.1.tar.gz 34496 BLAKE2B b5a60e3fe2408283afbdebf8efa709b7b1c96b82ddc76b3fbc4d58d544c2170de1434525fe2e324af9864332c6570885b05a3d8ec2c248fbff20984d2ee80a94 SHA512 319bb403970affd5a4222dfdb3d17738630d1350ea84e51ad1bebc6c8c72e0dcfd69a4eaf5e7bd156b8e605d806357922c05cc994dcafb01b7a33c617b2df447
diff --git a/dev-python/pkginfo/pkginfo-1.2.1.ebuild b/dev-python/pkginfo/pkginfo-1.2.1.ebuild
deleted file mode 100644
index 52800837a32d..000000000000
--- a/dev-python/pkginfo/pkginfo-1.2.1.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
-HOMEPAGE="https://pypi.org/project/pkginfo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
-IUSE="doc examples"
-
-LICENSE="MIT"
-SLOT="0"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-python_prepare_all() {
- # Disable tests that seek to read the version of pkginfo from an installed state
- # These test will still become installed and testable once installed
- sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
- -e 's:test_w_module_and_metadata_version:_&:' \
- -e 's:test_w_package_name_and_metadata_version:_&:' \
- -i pkginfo/tests/test_utils.py || die
- sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
- -i pkginfo/tests/test_develop.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Test ${test} failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/.build/html/. )
- if use examples; then
- dodoc -r docs/examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/pkginfo/pkginfo-1.4.2.ebuild b/dev-python/pkginfo/pkginfo-1.4.2.ebuild
deleted file mode 100644
index b2f0a7150e32..000000000000
--- a/dev-python/pkginfo/pkginfo-1.4.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Provides an API for querying the distutils metadata written in a PKG-INFO file"
-HOMEPAGE="https://pypi.org/project/pkginfo/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
-IUSE="doc"
-
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-python_prepare_all() {
- # Disable tests that seek to read the version of pkginfo from an installed state
- # These test will still become installed and testable once installed
- sed -e 's:test_w_directory_no_EGG_INFO:_&:' \
- -e 's:test_w_module_and_metadata_version:_&:' \
- -e 's:test_w_package_name_and_metadata_version:_&:' \
- -i pkginfo/tests/test_utils.py || die
- sed -e 's:test_ctor_w_path_nested_egg_info:_&:' \
- -i pkginfo/tests/test_develop.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/.build/html/. )
- distutils-r1_python_install_all
-}