summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAisha Tammy <gentoo@aisha.cc>2020-09-22 21:28:43 -0400
committerBenda Xu <heroxbd@gentoo.org>2020-11-09 15:54:02 +0800
commite6c6f26ab199eb11f4479d6870de262f9a9fb53d (patch)
treeacb97cc33bebe2214b38e6b5ae8f771cbad769d8 /dev-python/plotly/plotly-4.10.0.ebuild
parentsys-kernel/git-sources: Automated version bump to 5.10_rc3. (diff)
downloadgentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.tar.gz
gentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.tar.bz2
gentoo-e6c6f26ab199eb11f4479d6870de262f9a9fb53d.zip
dev-python/plotly: version bump to 4.10.0
Closes: https://bugs.gentoo.org/641650 Closes: https://github.com/gentoo/gentoo/pull/17643 Reported-by: Martin H, Anton Bolshakov Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Aisha Tammy <gentoo@aisha.cc> Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Diffstat (limited to 'dev-python/plotly/plotly-4.10.0.ebuild')
-rw-r--r--dev-python/plotly/plotly-4.10.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/plotly/plotly-4.10.0.ebuild b/dev-python/plotly/plotly-4.10.0.ebuild
new file mode 100644
index 000000000000..24a60e316802
--- /dev/null
+++ b/dev-python/plotly/plotly-4.10.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plot.ly/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/retrying[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ mkdir -p "${ED}"/etc/ || die
+ mv "${ED}"/usr/etc/jupyter "${ED}"/etc/ || die
+ rmdir "${ED}"/usr/etc || die
+}