summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:35:09 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2021-08-24 20:41:13 +0200
commit4eb55de6a7c4d57b4191a58047b0a6d6ee0d4cf3 (patch)
treec184c418a58df3a61378a18abf7f006126ff2e3d /dev-python/plotly
parentdev-python/ipykernel: add version 6.2.0 (diff)
downloadgentoo-4eb55de6a7c4d57b4191a58047b0a6d6ee0d4cf3.tar.gz
gentoo-4eb55de6a7c4d57b4191a58047b0a6d6ee0d4cf3.tar.bz2
gentoo-4eb55de6a7c4d57b4191a58047b0a6d6ee0d4cf3.zip
dev-python/plotly: add version 5.2.2
Closes: https://bugs.gentoo.org/808105 Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/plotly')
-rw-r--r--dev-python/plotly/Manifest1
-rw-r--r--dev-python/plotly/plotly-5.2.2.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/plotly/Manifest b/dev-python/plotly/Manifest
index ba21cf695ea4..3c08fb3d0746 100644
--- a/dev-python/plotly/Manifest
+++ b/dev-python/plotly/Manifest
@@ -1,2 +1,3 @@
DIST plotly-4.14.1.tar.gz 6373585 BLAKE2B 8e8d15a7f68bbef835fcbc0048c2457916aad1b10e06c903222030b2b2e1b902e2d42080f8ac2c19928dabd7e1623210930b9f33dededa71dbbb28b2f41f848c SHA512 e052680d0e7344b9f53f1b917dd0b9bc87b0c34300d93b8958ccb35b38f9dc5e7fb4db016d1113df4bae78c419f3d378112c59c3470723ce1349eaadbc5011f8
DIST plotly-4.14.3.tar.gz 6374650 BLAKE2B 91d950b6365876b03b2b0393c642275c37fc352fda90ce010310f5dae046c3cdd835de438036c5d92fd35d3afcd2c7b8548a87b1354d4a33cd2cfe10838ae94d SHA512 7d8db7a0f6c1abeda1b222f9bd25e4395dd8d14d246ad986960868a8083e4f1d1f600d84f44416eb1d089640d190192e931b5a5f6ae24e01cf8146c4cf8e80eb
+DIST plotly-5.2.2.tar.gz 7293292 BLAKE2B baef3accf8f5a3085908fcea558f8003687e18a1f97471c620c378c10d23d4222ef87dc47d64f45199b594414890db5b8ca5e3d7867c871d926c2ae441128c4a SHA512 4d6d79f7cc2063e73e7c17ff90a7d13324497ea8034d8ce62d79ec62b0530a59b2eaec8913fb05efb804cf5be8387b6f96d1710f41b9993233b5a13cf64dd310
diff --git a/dev-python/plotly/plotly-5.2.2.ebuild b/dev-python/plotly/plotly-5.2.2.ebuild
new file mode 100644
index 000000000000..7320a8a0913e
--- /dev/null
+++ b/dev-python/plotly/plotly-5.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Browser-based graphing library for Python"
+HOMEPAGE="https://plotly.com/python/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+# The GitHub tarball contains the tests, but it excludes other things which have
+# to be fetched with npm and therefore it does not work in the network-sandbox.
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/tenacity-6.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.15.0[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ mkdir -p "${ED}"/etc/ || die
+ mv "${ED}"/usr/etc/jupyter "${ED}"/etc/ || die
+ rmdir "${ED}"/usr/etc || die
+}