summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 15:37:39 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 17:01:12 +0200
commit48bd6691289e04140bb14e272dbb95b64c77012d (patch)
treef2c502002a3cfbd259bfccb77b3dbb17f4c198cb /dev-python/pluggy/pluggy-1.0.0-r2.ebuild
parentdev-python/pluggy: Remove old (diff)
downloadgentoo-48bd6691289e04140bb14e272dbb95b64c77012d.tar.gz
gentoo-48bd6691289e04140bb14e272dbb95b64c77012d.tar.bz2
gentoo-48bd6691289e04140bb14e272dbb95b64c77012d.zip
dev-python/pluggy: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/pluggy/pluggy-1.0.0-r2.ebuild')
-rw-r--r--dev-python/pluggy/pluggy-1.0.0-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/pluggy/pluggy-1.0.0-r2.ebuild b/dev-python/pluggy/pluggy-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..8655fc6560ad
--- /dev/null
+++ b/dev-python/pluggy/pluggy-1.0.0-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Plugin and hook calling mechanisms for Python"
+HOMEPAGE="
+ https://pluggy.readthedocs.io/
+ https://github.com/pytest-dev/pluggy/
+ https://pypi.org/project/pluggy/
+"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest